XF 2.1 Error on Registration

Ludachris

Well-known member
I just got an email from a person trying to register and I cannot replicate it. The user tried both Firefox and Chrome on Mac and Android and got the same error. There are no errors logged in ACP and I didn't see anything in the server error log file. The site is using Cloudflare, if that matters. Here's the error messages they sent me...

Oops! We ran into some problems. Please try again later. More error details may be in the browser console.

Browser console messages:
09:56:23.360
Warning processing windowTypes: This property is deprecated global.min.js:250
09:56:28.805
Warning processing windowTypes: This property is deprecated global.min.js:250
09:56:28.806
a is undefined global.min.js:250
09:56:28.806
Unchecked lastError value: Error: Invalid window ID: 4368 global.min.js:250
a moz-extension://c133becd-e8c6-ab47-afff-8308f7bddd7f/global.min.js:250
09:56:42.582
Warning processing windowTypes: This property is deprecated global.min.js:250
09:57:17.469
Warning processing windowTypes: This property is deprecated global.min.js:250
09:57:17.473
a is undefined global.min.js:250
a moz-extension://c133becd-e8c6-ab47-afff-8308f7bddd7f/global.min.js:250
apply self-hosted:1870
applySafeWithoutClone resource://gre/modules/ExtensionCommon.jsm:614
wrapPromise resource://gre/modules/ExtensionCommon.jsm:843
withLastError resource://gre/modules/ExtensionCommon.jsm:762
wrapPromise resource://gre/modules/ExtensionCommon.jsm:831
09:57:17.473
Unchecked lastError value: Error: Invalid window ID: 4368 global.min.js:250
 

Mike

XenForo developer
Staff member
It's not really clear if those errors are related, but none of those come from XF -- they all appear to be related to browser extensions. That would seem to point to that being the issue, though it's hard to say if they're getting it in multiple browsers.

If you can't reproduce it and haven't had any other reports, you may just want to manually create an account for the user.
 

Ludachris

Well-known member
It's not really clear if those errors are related, but none of those come from XF -- they all appear to be related to browser extensions. That would seem to point to that being the issue, though it's hard to say if they're getting it in multiple browsers.

If you can't reproduce it and haven't had any other reports, you may just want to manually create an account for the user.
That's what I've done. He says when he went logged in and went to change the pw he got the error again. But when he chose another pw it worked. The pw that kicked back the error was 1pE>f_.lE><f ....Not sure why it would be tied to a character in the pw.
 
Top