1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Error on Post Thread Page

Discussion in 'Troubleshooting and Problems' started by Ablac, Nov 21, 2012.

  1. Ablac

    Ablac Active Member

    Threads post correctly but in debug mode i get this error.

    Code:
    Template Errors: thread_view
    Illegal string offset 'thumbnailUrl' in /var/www/internal_data/templates/S.2,L.1,thread_view.php, line 2085
    Illegal string offset 'thumbnailUrl' in /var/www/internal_data/templates/S.2,L.1,thread_view.php, line 2089
    Illegal string offset 'filename' in /var/www/internal_data/templates/S.2,L.1,thread_view.php, line 2104
    Illegal string offset 'filename' in /var/www/internal_data/templates/S.2,L.1,thread_view.php, line 2112
    Not sure how to fix it.

    Heres Lines 2077 - 2114 of that file that the error calls.
    PHP:
    $__compilerVar73 '';
    $__compilerVar73 .= '1';
    $__compilerVar74 '';
    $__compilerVar75 '';
    $this->addRequiredExternal('css''attachment_editor');
    $__compilerVar75 .= '
     
    <li id="' 
    . (($__compilerVar73) ? ('AttachedFileTemplate') : ('attachment' htmlspecialchars($__compilerVar74['attachment_id']))) . '"
        class="AttachedFile ' 
    . (($__compilerVar74['thumbnailUrl']) ? ('AttachedImage') : ('')) . ' secondaryContent">
     
        <div class="Thumbnail">
            '
    ;
    if (
    $__compilerVar74['thumbnailUrl'])
    {
    $__compilerVar75 .= '
                <a href="' 
    XenForo_Template_Helper_Core::link('attachments'$__compilerVar74, array()) . '" target="_blank"
                    data-attachmentId="' 
    htmlspecialchars($__compilerVar74['attachment_id']) . '"
                    class="_not_LbTrigger" data-href="' 
    XenForo_Template_Helper_Core::link('misc/lightbox'false, array()) . '"><img
                    src="' 
    htmlspecialchars($__compilerVar74['thumbnailUrl']) . '" alt="' htmlspecialchars($__compilerVar74['filename']) . '"
                    class="_not_LbImage" data-src="' 
    XenForo_Template_Helper_Core::link('attachments'$__compilerVar74, array(
    'embedded' => '1'
    )) . '" /></a>
            '
    ;
    }
    else
    {
    $__compilerVar75 .= '
                <!--<img src="' 
    XenForo_Template_Helper_Core::styleProperty('imagePath') . '/xenforo/widgets/page.png" alt="' htmlspecialchars($__compilerVar74['filename']) . '" />-->
                <span class="genericAttachment"></span>
            '
    ;
    }
    $__compilerVar75 .= '
        </div>
     
        <div class="AttachmentText">
            <div class="Filename"><a href="' 
    XenForo_Template_Helper_Core::link('attachments'$__compilerVar74, array()) . '" target="_blank">' htmlspecialchars($__compilerVar74['filename']) . '</a></div>
       
            '
    ;
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

Share This Page