1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Error on import from IPB 4.1.11 to Xenforo 1.5.7

Discussion in 'Installation, Upgrade, and Import Support' started by Kev Collins, May 11, 2016.

  1. Kev Collins

    Kev Collins Member

    When running the importer I have got this message when importing threads and posts.
    It's a clean database I'm installing into.
    Could you give any pointers how to overcome this please.

    Many thanks,

    Server Error
    Mysqli statement execute error : Duplicate entry '2' for key 'PRIMARY'

    1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    3. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    4. Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1638
    5. XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1627
    6. XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1419
    7. XenForo_DataWriter->save() in XenForo/Model/Import.php at line 617
    8. XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 1627
    9. XenForo_Model_Import->importThread() in XenForo/Importer/IPBoard.php at line 2657
    10. XenForo_Importer_IPBoard->stepThreads() in XenForo/Importer/IPBoard40x.php at line 1428
    11. XenForo_Importer_IPBoard40x->stepThreads() in XenForo/Importer/Abstract.php at line 124
    12. XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 189
    13. XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 241
    14. XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 184
    15. XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 351
    16. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    17. XenForo_FrontController->run() in /home/cwhtcouk/public_html/cwht/club-forum/admin.php at line 13
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Presumably you checked the 'retain IDs' option?

    Did you ever create any content in the new XF insallation and then delete it prior to running the import?
  3. Kev Collins

    Kev Collins Member

    Yes retained IDs'

    I did create a message and delete it in the default made forum.
  4. Brogan

    Brogan XenForo Moderator Staff Member

  5. Kev Collins

    Kev Collins Member

    Many thanks Brogran and thank you for such a quick response.


Share This Page