1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Error message - please help!

Discussion in 'Troubleshooting and Problems' started by happymango, Sep 3, 2013.

  1. happymango

    happymango Member

    Hi,

    I am getting the following message and don't know why.

    Server Error

    Mysqli prepare error: INSERT command denied to user 'foradb_2'@'linweb10.atlas.pipex.net' for table 'xf_session_admin'

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    5. Zend_Db_Adapter_Abstract->insert() in XenForo/Session.php at line 760
    6. XenForo_Session->saveSessionToSource() in XenForo/Session.php at line 501
    7. XenForo_Session->save() in XenForo/Controller.php at line 412
    8. XenForo_Controller->updateSession() in XenForo/Controller.php at line 356
    9. XenForo_Controller->postDispatch() in XenForo/FrontController.php at line 344
    10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    11. XenForo_FrontController->run() in /websites/123reg/LinuxPackage22/fo/ra/_c/fora.co.uk/public_html/admin.php at line 13
     
  2. Dan

    Dan Well-Known Member

    Looks like a permission issue. make sure your mysql user has the proper permissions.
     
  3. happymango

    happymango Member

    Thanks goblues. I think you're right. I guess I'll have to contact my hosting service - I have no idea why the mysql user permissions would have changed...

    UPDATE: Site working fine when I checked again this morning. Thanks for pointing me in the right direction goblues - after reading up on it, I think you were right in saying the mysql permissions had been changed. I still have no idea why this happened, but will only look into it if the same error occurs again. I guess the good thing about getting an error is you get to learn something...
     
    Last edited: Sep 4, 2013
  4. happymango

    happymango Member

    UPDATE 2: Error is back again! Will contact my hosting service...Yesterday I signed up for google analytics and inserted my Tracking ID via the XF Admin CP. Have just noticed that the return of the error message has coincided with the time that google analytics last tried to detect the tracking code...
     
  5. borbole

    borbole Well-Known Member

    That shouldn''t have any affect on it.
     
  6. happymango

    happymango Member

    OK - thanks borbole - guess that's just a coincidence
     
  7. happymango

    happymango Member

    My hosting service has now looked into the problem and responded:

    "I see that the database is created on our servers, but the connection to it is not made. I suggest to contact a web developer in order to sort this problem because we do not offer support for code issues. The problem seems to be related with the way in which the database connection is made from the PHP scripts that are uploaded in the web space."


    I can log in to my database using the user name and password given in the config.php file for the forum via phpMyAdmin. However, I still get the error message in my initial post when I try use the site.

    Any help is much appreciated. I have no idea about how to go about fixing this.
     
  8. Mike

    Mike XenForo Developer Staff Member

    This is entirely a permission configuration issue in MySQL: http://stackoverflow.com/questions/5698981/insert-command-denied-in-mysql

    I don't know your host's configuration, but the server you are connecting from is very significant to MySQL permissions (looks like linweb10.atlas.pipex.net). This is something only your host can resolve though. Either they need to resolve the permission issues or you need to connect to a different MySQL server or from a different web server.
     
    happymango and Adam Howard like this.
  9. happymango

    happymango Member

    Thank you Mike. I linked your reply to my hosting support ticket and got this response:

    "Yes, this is correct. I've checked in your database and you do not have the option to use this command: "INSERT". The problem is that your database already has exceeded the quota limit."


    I upgraded my hosting package so that my database was within the new size limits and the problem went away.

    Not sure how long it would have taken them to find the problem without your post. I can't thank you enough :D
     

Share This Page