XF 1.4 Error After Upgrading to PHP 7.

Imgbi

Member
I upgraded to PHP 7 and have been getting this errors.

Code:
ErrorException: Fatal Error: Uncaught TypeError: Argument 1 passed to XenForo_Application::handleException() must be an instance of Exception, instance of Error given in /var/www/.../library/XenForo/Application.php:375 Stack trace: #0 [internal function]: XenForo_Application::handleException(Object(Error)) #1 {main} thrown - library/XenForo/Application.php:375
Generated By: ... 2 minutes ago
Stack Trace
#0 [internal function]: XenForo_Application::handleFatalError()
#1 {main}
Request State
array(3) {
  ["url"] => string(84) "......./"
  ["_GET"] => array(1) {
    ["/threads/......./"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}
 
Last edited:

Ernest L. Defoe

Well-known member
I believe they added PHP7 support with the 1.5.x series. So you'll either need to renew your license to get access to the latest version or downgrade PHP.
 

Triops

Well-known member
BTW - Am I right when saying that each and every addon has to be checked for compatibility with PHP7?
 

Imgbi

Member
Thanks all, I've extended my license and upgraded. Everything is now working.
The performance improvement of PHP 7 should not be missed!
Like the version of Widget Framework that's posted here won't work. You have to get the version from the developers site
Please where do I get the one for 1.5? I only saw one in Github, don't know if it will work.
 
Top