• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Emails Not All Being Sent

#1
We've been trying to figure this one out for a couple weeks now. Using XF 1.5.1 and running PostFix 2.11.0. Many emails are being sent, but some users (most notably another admin) are only receiving notifications for a few select threads and conversations.

I had our hosting company take a look at this and they tweaked postfix to improve it's performance some, but there doesn't seem to be a problem on their end. The server reports 0 messages in the queue. Any ideas?
 

Mike

XenForo developer
Staff member
#2
They should be able to look at the raw error logs to see the result of the mails being queued and sent (in case there's an error). There wouldn't be anything that would vary from conversation to conversation for example -- it should be sent consistently.
 

Mike

XenForo developer
Staff member
#4
No. If they can see the conversation, they would get the email. (They could choose not to receive emails, but they wouldn't get them for some conversations then.)
 
#5
No. If they can see the conversation, they would get the email. (They could choose not to receive emails, but they wouldn't get them for some conversations then.)
Thanks, I'm more libel to think that he is somehow having the emails intercepted. We had a similar problem when we first started when our emails were being rejected as spam by gmail and aol due to someone who used to have our domain.
 

Tracy Perry

Well-known member
#6
If your mail is being rejected by gmail/hotmail/etc. then there should be a notation in your MTA mail log on the 550 reject reason.
 

Mike

XenForo developer
Staff member
#7
Doh! That's what I was trying to say initially -- I just noticed I said raw "error log" instead of "email log"! The MTA log should show every email handed to it.