• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Email options not saving SMTP username

Mr Lucky

Well-known member
#1
Whenever I save my email options, the Transport method my SMTP (Amazon SES) username is not saving, instead it reverts to my xenforo username in the field.

Can any help please?
 

Chris D

XenForo developer
Staff member
#5
It's actually fairly difficult to override these days. Even if you explicitly set fields to autocomplete="off" if browsers see fit then they will still autofill a username and password field.

I don't personally use Safari but it should be possible to disable autofill or remove the saved credentials for that page.
 

Mr Lucky

Well-known member
#6
Thing is I find it very handy when logging in, but in this case it seems to be behaving oddly.

Even after I have saved the correct SMTP username , the field just shows the autofill username. Hence it appears that it isn't saving the correct one.

Also if you adjust some parameter on that page (e.g. minimum number of bounces) and then hit save, it changes the previously saved username to the default login autofill.

I did this yesterday, and for several hours email notifications stopped working. It was only by chance that I noticed the username was the wrong one.

I have not found a way for safari to disable this on specific pages, that would be good but ideally I don't think it should autofill if there is already another name saved in that filed.
 

Steve F

Well-known member
#7
It's actually fairly difficult to override these days. Even if you explicitly set fields to autocomplete="off" if browsers see fit then they will still autofill a username and password field.

I don't personally use Safari but it should be possible to disable autofill or remove the saved credentials for that page.
You've maybe seen this but
https://developer.mozilla.org/en-US...ing_your_site/Turning_off_form_autocompletion

I find nearly all auto fill actions annoying these days, especially with password managers. Auto filling fields that have nothing to do with usernames, like style property text fields and such.
 

Mr Lucky

Well-known member
#9
I find nearly all auto fill actions annoying these days, especially with password managers. Auto filling fields that have nothing to do with usernames, like style property text fields and such.
Well, it's no problem on Firefox, it doesn't fill it in "by stealth" without you knowing as Safari does