1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Email Notifications Not Sending After Moving Host

Discussion in 'Troubleshooting and Problems' started by System0, Apr 21, 2015.

  1. System0

    System0 Active Member

    I am sending emails using SMTP through a third-party emailing service (using username and password and SSL encryption).

    Everything was working perfectly, however ten days ago I moved to a new host and now email notifications are not sending.

    Why would moving to a new host stop email notifications from working if I am using a third-party mail service?

    Doesn't sending SMTP emails through an external service bypass whatever settings are on my server?

  2. Tracy Perry

    Tracy Perry Well-Known Member

    Check your firewall to make sure it allows outbound connections on that port you are using.
  3. System0

    System0 Active Member

    Thanks Tracy. I will check that just now.
  4. System0

    System0 Active Member

    I checked the firewall configuration.

    I looked at "Allow outgoing TCP ports" and noticed that the outgoing port was not added. However, I looked back at the settings on my old server and noticed that the port was not added there either.

    Am I looking at the right section or am I way off?
  5. Tracy Perry

    Tracy Perry Well-Known Member

    What firewall are you using? CSF will block all ports that are not specifically added to the allowance. If you are using cPanel, and it's not using CSF, then there may be other areas to set.
    I don't use a panel and do all my stuff via SSH and the command line.
  6. System0

    System0 Active Member

    Yeah I am using "ConfigServer Security & Firewall" too.

    Why was email notifications working in my last server if the outgoing port was not enabled?
  7. Tracy Perry

    Tracy Perry Well-Known Member

    The server IP may have been in the CSF.allow list. That will allow it to have access to any/all ports no matter what the block settings are.
    System0 likes this.
  8. System0

    System0 Active Member

    (Sorry, thought I replied to this earlier).

    I had not added any IP addresses to the allow list for mailing. All I had to do was use the correct username and password to XenForo.

    I'll speak to my host and see if anything from the server configuration could be stopping this from working.

Share This Page