• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Email Notifications Being Received

System0

Active member
#1
I have all of my emails going through GoDaddy's Premium DNS service. On one of my websites I have WordPress in the front end and XenForo in the member area.

I noticed that email notifications are not being received for new private messages etc. Email notifications are enabled in my profile and the WHM panel shows that the email has been sent. Yet no emails are being received in my main inbox or in my spam folder.

My first thought was that this was either a hosting configuration issue or a DNS issue. The reason that I believe this could be something to do with XenForo is because emails are being received correctly through the contact form in WordPress (via the front end of the site).

I have another XenForo forum hosted by another company and the configuration settings are identical, so I am unsure as to whether hosting settings are the problem.

Does XenForo require anything to be modified in order to send emails correctly? I am unsure as to whether one host has changed my XenForo setup in order to send emails correctly and the other host hasn't.

Any help on this would be appreciated (particularly from those who also use a third-party DNS service) :)

Kevin
 

Liam W

Well-known member
#2
Is one host using SMTP and the other using the PHP mail() function?

I would recommend letting them all use SMTP, if possible...

Liam
 

Brogan

XenForo moderator
Staff member
#3
On the contrary, we generally recommend using the local PHP standard method, unless you have a compelling reason to use SMTP.
 

Brogan

XenForo moderator
Staff member
#5
The email settings are in the ACP -> Options -> Email Options

Have you confirmed the emails are being generated and sent by inspecting the server mail logs?
If so, they are being caught in a spam trap somewhere.
 

System0

Active member
#6
I checked both the forums I was referring to previously (i.e. one that does, one that doesn't) and the email transport method is set to default.

I just noticed something from the logs that I didn't notice before. The sender of the emails are noted as nobody@host.mywebsite.com rather than nobody@mywebsite.com. Looks like my hosting company had set up a different dns zone initially and this setting has remained for emails.

I will verify this with them right away to confirm.

Thanks for your help :)
 

System0

Active member
#7
Not surprisingly, my hosting company lays the blame on XenForo (I always enjoy these games of virtual pass the parcel!).

Hello Kevin,

The issue of the form mail sending as the hostname and not as JUST the domain name is due to your code. It will default to the hostname (host.yourwebsite.com) if you do not specify for it to send as "nobody@yourwebsite.com."

You will need to have your developer alter the site code to specify this address rather than it defaulting to the hostname address.

Regards,
----------
Michael G.
I guess this means that the sender name is irrelevant and will not, in any way, affect the delivery of an email.

Where else could these emails be caught as they are not being sent to the Gmail spam folder? Do you suggest speaking directly to my members and asking if they are experiencing the same problem.
 

System0

Active member
#8
All resolved. The hosting company had configured my email settings for me previously but hadn't added all the mx record entries. Appreciate the support :)