• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Email Issues

#1
I am seeing this in my mail logs.

Oct 30 03:12:29 fido postfix/smtp[28137]: A12BB8CBB9: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28136]: 09F698CBC5: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28134]: 848FD8CBC1: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28141]: 8DA828CBBD: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28143]: 726B48CBCF: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28138]: 9EEBB8CBA9: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:29 fido postfix/smtp[28140]: D9D4B8CBBB: host cdptpa-smtpin01.mail.rr.com[75.180.132.243] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP
Oct 30 03:12:31 fido postfix/smtp[28137]: A12BB8CBB9: to=<bmeuron@cfl.rr.com>, relay=cdptpa-smtpin02.mail.rr.com[75.180.132.244]:25, delay=8791, delays=8787/0.04/4.1/0, dsn=4.7.1, status=deferred (host cdptpa-smtpin02.mail.rr.com[75.180.132.244] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP)
Oct 30 03:12:32 fido postfix/smtp[28136]: 09F698CBC5: to=<knicholson@carolina.rr.com>, relay=cdptpa-smtpin02.mail.rr.com[75.180.132.244]:25, delay=8789, delays=8785/0.03/4.2/0, dsn=4.7.1, status=deferred (host cdptpa-smtpin02.mail.rr.com[75.180.132.244] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP)
Oct 30 03:12:32 fido postfix/smtp[28141]: 8DA828CBBD: to=<msantarelli@roadrunner.com>, relay=cdptpa-smtpin02.mail.rr.com[75.180.132.244]:25, delay=8790, delays=8786/0.06/4.1/0, dsn=4.7.1, status=deferred (host cdptpa-smtpin02.mail.rr.com[75.180.132.244] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP)

Oct 30 03:12:32 fido postfix/smtp[28140]: D9D4B8CBBB: to=<simon101@roadrunner.com>, relay=cdptpa-smtpin02.mail.rr.com[75.180.132.244]:25, delay=8785, delays=8781/0.06/4.2/0, dsn=4.7.1, status=deferred (host cdptpa-smtpin02.mail.rr.com[75.180.132.244] refused to talk to me: 421 4.7.1 - Connection refused - <50.116.38.38> - Too many concurrent connections from source IP)


I believe it is because it is trying to send too many emails in too short of a span of time. Is there any way to put a pause in?

--Dan
 

Jeremy

Well-known member
#3
Your SMTP server appears to be rejecting connections due to too many being active at the same time. You'll need to talk to your host to determine if there is a script consistently sending emails or contact your email provider to help diagnose the problem.
 
#4
I am the host. It is a virtual server. This message is being sent back. It is hitting multiple forum members who have the same internet provider.

If you look at the message, it is coming from....
75.180.132.243

My host and smtp service is
50.116.38.38

eth0 Link encap:Ethernet HWaddr F2:3C:91:AE:45:80
inet addr:50.116.38.38 Bcast:50.116.38.255 Mask:255.255.255.0
inet6 addr: 2600:3c02::f03c:91ff:feae:4580/64 Scope:Global
inet6 addr: fe80::f03c:91ff:feae:4580/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:32257481 errors:0 dropped:0 overruns:0 frame:0
TX packets:25039000 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:5415445797 (5.0 GiB) TX bytes:39603836335 (36.8 GiB)
Interrupt:76

I need something that will cause the emails to forum members to pause in between sends. This should cause the receiving end to understand that it is not being attacked.

--Dan
 

Jeremy

Well-known member
#7
If you are the host and have access, you'll need to tune the settings on your server for the amount of emails your site requires sending.
 
#8
I started noticing this about 1 week ago but believe it has happened before. The issue also caused me to get black-listed. I have taken measures to rectify that.

Does anyone know how to tune email from a LINUX perspective?

--Dan
 

Tracy Perry

Well-known member
#10
I started noticing this about 1 week ago but believe it has happened before. The issue also caused me to get black-listed. I have taken measures to rectify that.

Does anyone know how to tune email from a LINUX perspective?

--Dan
Here ya' go.
So, you have this huge mailhub with tons of disk and memory, and have configured Postfix to run up to 1000 SMTP client processes at the same time. Congratulations. But do you really want to make 1000 simultaneous connections to the same remote system? Probably not.
The Postfix queue manager comes to the rescue. This program implements the analog of the TCP slow start flow control strategy: when delivering to a site, send a small number of messages first, then increase the rate as long as all goes well; back off in the face of congestion.

The initial_destination_concurrency parameter (default: 2) controls how many messages are initially sent to the same destination before adapting delivery concurrency. Of course, this setting is effective only as long as it does not exceed the process limit and the destination concurrency limit for the specific mail transport channel.

The default_destination_concurrency_limit parameter (default: 10) controls how many messages may be sent to the same destination simultaneously. You can override this setting for specific delivery channels (local, smtp, uucp etc.). The main.cf file recommends the following:

local_destination_concurrency_limit = 2
default_destination_concurrency_limit = 10
The local_destination_concurrency_limit parameter controls how many messages are delivered simultaneously to the same local recipient. The recommended limit is low because delivery to the same mailbox must happen sequentially, so massive parallelism is not useful. Another good reason to limit delivery concurrency to the same recipient: if the recipient has an expensive shell command in her .forward file, or if the recipient is a mailing list manager, you don't want to run too many instances at the same time.
A destination concurrency limit of 10 for SMTP delivery seems enough to noticeably load a system without bringing it to its knees. Be careful when changing this to a much larger number.
found via Google at http://www.hsc.fr/ressources/cours/postfix/doc/rate.html#destination
and another one http://steam.io/2013/04/01/postfix-rate-limiting/

The second one has some REALLY good information. Tells how to even set it so that it throttles for certain domains to run even slower than default using /etc/postfix/transport file to define domains.
 
#12
If I reduce the number for default_destination_concurrency_limit

Will this keep me from flooding the remote destinations and help with the issue that I have experienced?
If 10 is the default, I was thinking of maybe something like 2 or 3.

--Dan
 

Tracy Perry

Well-known member
#13
If I reduce the number for default_destination_concurrency_limit

Will this keep me from flooding the remote destinations and help with the issue that I have experienced?
If 10 is the default, I was thinking of maybe something like 2 or 3.

--Dan
The second link gives you the most detailed information. I think he used the example for main.cf of smtp_destination_concurrency_limit = 2.
 

Brogan

XenForo moderator
Staff member
#14
If you require help with a specific issue, please start a new thread detailing the problem rather than just posting on multiple existing threads in this manner.