• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Email: Connection Refused

#1
I am trying to use my Google Apps email to send my confirmation emails, unfortunately, after going through the settings over and over again. I keep getting this same error

Email to [EMAIL ADDRESS] failed: Connection refused

When I click on the error, this is what comes up.

Error Info
Zend_Mail_Protocol_Exception: Email to [EMAIL ADDRESS] failed: Connection refused - library/Zend/Mail/Protocol/Abstract.php:277
Generated By: Unknown Account, A moment ago
Stack Trace
#0 /home/crimecoastforums/public_html/library/Zend/Mail/Protocol/Smtp.php(167): Zend_Mail_Protocol_Abstract->_connect('ssl://smtp.gmai...')
#1 /home/crimecoastforums/public_html/library/Zend/Mail/Transport/Smtp.php(216): Zend_Mail_Protocol_Smtp->connect()
#2 /home/crimecoastforums/public_html/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 /home/crimecoastforums/public_html/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 /home/crimecoastforums/public_html/library/XenForo/Mail.php(175): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#5 /home/crimecoastforums/public_html/library/XenForo/Mail.php(152): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 /home/crimecoastforums/public_html/library/XenForo/Model/UserConfirmation.php(241): XenForo_Mail->send('[EMAIL ADDRESS]', '[USERNAME]')
#7 /home/crimecoastforums/public_html/library/XenForo/ControllerPublic/LostPassword.php(84): XenForo_Model_UserConfirmation->sendPasswordResetRequest(Array)
#8 /home/crimecoastforums/public_html/library/XenForo/FrontController.php(351): XenForo_ControllerPublic_LostPassword->actionLost()
#9 /home/crimecoastforums/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /home/crimecoastforums/public_html/index.php(13): XenForo_FrontController->run()
#11 {main}
Request State
array(3) {
["url"] => string(46) "http://crimecoastforums.com/lost-password/lost"
["_GET"] => array(0) {
}
["_POST"] => array(3) {
["username_email"] => string(18) "[EMAIL ADDRESS"
["g-recaptcha-response"] => string(932) "03AHJ_Vut7ZZqXOdKgwHm0oh7PRTRGRzJEyuulxw1ke6y2HRqZj4BklWLgu1bOgDgx9Hhyl246qbQtM6GEa93uw9lbIj2mVvEfNgZVdCePLbleQQLrCzjUFKssZgJCR8kvH1NSAv_mtQe-AYKggLg8ajZct9ZKuBsfcS5fI4MSFpF2jMgYCAl3qN1OK2HNWL_d8Ns6iXy0-yN3vG_I8KnuQU7u535SwXMlyMBKy95ak2yj6ODP7V16F6vXju0JT2xkoJ0pOJO5XtgR2wky1bX26Rmk-mfMD5oC-0eE_mB9jImz9s_M4Nj0XtUX5LhMn9TrWWN8GEbV-uTYGczzQNMDFqSV_iFI17k50VSg4dKaGthPfpUr5FGuwhTpa-xMj226kC22CRfzQTEhpn4y8mUGGZhrcCZ-of3ds4-3TPAvm6aYd7GWN9-t2_O7N3m4-8l1fr4m4Fezl36hEqyvXkIBV4m6D5uPBDgvb2FAx8rfkWKkvVXg4HI-W6dXgYhvtr2_hZWsb8orA7OFdakS05qldaCfpNZYFIvSrHYFzjGoZDuyYEwuKhedeDbYJdBWPCLZrAl9mcGi_dxNg7IFcX9JLY1qMCgGO6uBqWp8DI3nIX7s_1XYq2wv0n06cKu6MQpkU9py3v_hzcC1TVN_9bJkQICkdajwDcEsRInaEUHl2RVStxHhA3GCOpk2-HKHsusNar6_dvgeDjZnIqjUPgNRl_nfjgXcMnqOOn_GpRXUMl7lUlz8Qxp6bGxfD8n26DHJpg15RNWMWe7j8YJXSzZ4pVg1GRuzYRKxIXwWGYWOThg7BphZ32KaIwEsKl7pZzrl_acqP-hADy4SKKzO7aHtPqKD1I5MgSsaT4VdOSgIdORdbI0eIsIJ0YWqrYULn1bQ6dman2iprVAfwdPkIGeOGF1LcyAf5D--HA"
["_xfToken"] => string(8) "********"
}
}
 

Mike

XenForo developer
Staff member
#2
This is indicating that the connection to your SMTP server failed. Specifically, it was blocked. This might be an outgoing firewall blocking your request. If you're 100% sure that you entered the right SMTP details, then you may want to check with your host to see if they're blocking connections.
 

Mike

XenForo developer
Staff member
#4
Usually your web host, but can you screenshot your email configuration in XF? (You can hide the username and password part.)
 

Mike

XenForo developer
Staff member
#7
You previously mentioned that SMTP relaying was blocked on your hosting. Is that not the case?

Based on your use of smtp-relay.gmail.com, have you entered your server's IP as an allowed sender? There are a few options you can use here. If you want to use the SMTP relay, there are other steps you need to take. See https://support.google.com/a/answer/176600?hl=en for more details.