1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Email bounce error

Discussion in 'Troubleshooting and Problems' started by Moscato, Feb 15, 2015.

  1. Moscato

    Moscato Active Member

    I keep getting this error

    Zend_Mail_Protocol_Exception: cannot read - connection closed? - library/Zend/Mail/Protocol/Imap.php:139
    Generated By: Unknown Account, A moment ago
    Stack Trace
    #0 /srv/http/techraptor/community/library/Zend/Mail/Protocol/Imap.php(155): Zend_Mail_Protocol_Imap->_nextLine()
    #1 /srv/http/techraptor/community/library/Zend/Mail/Protocol/Imap.php(104): Zend_Mail_Protocol_Imap->_assumedNextLine('* OK')
    #2 /srv/http/techraptor/community/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('imap.gmail.com', 993, 'TLS')
    #3 /srv/http/techraptor/community/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
    #4 /srv/http/techraptor/community/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
    #5 /srv/http/techraptor/community/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.9999978542328, '')
    #6 /srv/http/techraptor/community/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999978542328, '', false)
    #7 /srv/http/techraptor/community/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
    #8 /srv/http/techraptor/community/deferred.php(23): XenForo_Model_Deferred->run(false)
    #9 {main}
    Request State
    array(3) {
    ["url"] => string(44) "http://techraptor.net/community/deferred.php"
    ["_GET"] => array(0) {
    ["_POST"] => array(4) {
    ["_xfRequestUri"] => string(20) "/community/admin.php"
    ["_xfNoRedirect"] => string(1) "1"
    ["_xfToken"] => string(8) "********"
    ["_xfResponseType"] => string(4) "json"


    My firewall rules are:

    Chain INPUT (policy DROP)
    target prot opt source destination
    ACCEPT all --
    ACCEPT tcp -- tcp dpt:80
    ACCEPT tcp -- tcp dpt:443
    ACCEPT tcp -- tcp dpt:660
    LOG all -- LOG flags 0 level 4
    ACCEPT tcp -- tcp spt:80 state RELATED,ESTABLISHED
    ACCEPT tcp -- tcp spt:443 state RELATED,ESTABLISHED
    ACCEPT udp -- udp spt:53
    ACCEPT tcp -- tcp spt:53
    ACCEPT udp -- udp dpt:123
    ACCEPT tcp -- tcp spt:25
    ACCEPT tcp -- tcp spt:587
    ACCEPT tcp -- tcp dpt:993

    Chain FORWARD (policy DROP)
    target prot opt source destination

    Chain OUTPUT (policy ACCEPT)
    target prot opt source destination

    What am I doing wrong here?
  2. Mike

    Mike XenForo Developer Staff Member

    Is this happening every half hour?

    It seems to imply the connection is made but that it failed to read anything from the connection. I'm not seeing any obvious cause, but this is pretty much in the domain of the network stack or the network connection itself. Your IMAP settings look correct. It's worth trying POP3 to see if that makes a difference.
  3. Moscato

    Moscato Active Member

    I got it to work @Mike .

    I tested from thunderbird to make sure it wasn't my server.

    On thunderbird ssl mode worked, while starttls fails.

    On Xenforo, ssl works, while tls fails.

    I just found this forum post with google stating that gmail only supports ssl for anything but smtp, just fyi
  4. gavpeds

    gavpeds Active Member

    I am having this exact error I have tried everything. Talking to my host was no help as they don't seem to have a clue they are telling me to pu in smtp info for bounce but does this not need imap incoming?

Share This Page