• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Awaiting feedback elastic search needs a config disable option

#1
We just had a situation in which there was no path to our elastic search server. Admincp could not even be opened to turn off elastic search because it tries to connect to elastic search. In the end I tried to disable the option directly via database which also did not work (cached, I guess.) I had to change the hosts on our servers to force the attempted elastic search connections to immediately timeout (by pointing it to localhost).

Suggested fix: If elastic search cannot be connected to consistently for 5 minutes automatically disable it for 5 minutes.
 
#3
You can most likely replicate this by null routing your php server on your search server.

On search server: route add -host [ip of php server] reject

Of course they need to be different servers
 

Mike

XenForo developer
Staff member
#4
The only time XF tries to connect to your ES server is when it needs it. There's nothing in the control panel that does this except for the ES setup page or when rebuilding the cache. Now if you have something that's bringing ES info to another page like the control panel index, then that could cause an issue potentially. But you shouldn't have any issue accessing the options section directly (admin.php?options/).

However, push comes to shove, you can disable all of this via config.php by disabling add-ons: https://xenforo.com/help/disable-addons-config-php/ That should allow you to get into the control panel to either disable the XenForo Enhanced Search add-on itself or disable ES in the options.