1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Browser Issue Editor freezes in Chrome 10

Discussion in 'Resolved Bug Reports' started by Floren, Dec 20, 2010.

  1. Floren

    Floren Well-Known Member

    I'm using Gogole Chrome developer version 10.0.612.1 with Xen Beta5. If I try to post a reply or a new thread into your forums or mines, the editor freezes after I type few words. This issue does not occur on Beta2 version. Works fine in IE8, posting with it as we speak.
  2. Jeremy P

    Jeremy P Well-Known Member

    Can reproduce.. though I figured it was a Chrome 10 bug. Only started after I upgraded.
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Mike will be pleased...

    The Chrome developers seem to have a habit of introducing new bugs and/or regressing fixes from previous versions.
  4. Jeremy P

    Jeremy P Well-Known Member

    Well Chrome 10 is only on the Dev channel, so I guess it's bound to happen.
  5. SilverCircle

    SilverCircle Well-Known Member

    It is a Chrome issue. I have the same here, but only with the dev channel build. Version 10.x comes with a new JavaScript engine (crankshaft), so some major bugs are likely to exist.

    The current development build is quite unstable - I had some crashes and hangs on various sites, not only xF.
  6. Floren

    Floren Well-Known Member

    It is a Tiny MCE issue. All the sites I visit with Chrome work as expected, while using other WYSIWYG editors. What version is used in Xen? The latest version is and works with Chrome 10.
  7. Shadab

    Shadab Well-Known Member

    > tinyMCE.minorVersion

    > tinyMCE.majorVersion

    The latest version, it seems.
  8. SilverCircle

    SilverCircle Well-Known Member

    Even _if_ there is a bug in TinyMCE (which might very well be possible), the browser should definitely not enter a infinite loop, making it impossible to close the tab and hang forever - think about it, any webpage could use such JavaScript code to exploit this bug, crashing your browser.

    So just because another version of TinyMCE works doesn't mean there is no problem. There definitely are problems in the current Chrome dev builds and that's why they should not be used on production systems.

    Here is a related issue in the Chromium bug tracker (hang with TinyMCE in WordPress, both OS X and Windows versions affected).

    Try to play with about:flags and disable some of the more experimental stuff.
  9. dieketzer

    dieketzer Well-Known Member

    chrome is todays ie.
  10. Floren

    Floren Well-Known Member

    That is just another report confirming that there is an issue with the Wordpress implementation of Tiny MCE (jquery port). If you go to the Tiny MCE demo page, you will see it works perfect with Chrome 10.
  11. Pepelac

    Pepelac Well-Known Member

    No it doesn't. This is not a problem of WP only. Every page with TinyMCE on it hangs. But it can be OS specific problem (Mac OS and Windows 7 are involved, it's written in comments)
  12. Floren

    Floren Well-Known Member

    I see, thanks for the info. I tried to edit several parts on their demo page and it did not freeze anything.
    I guess I was lucky... :)

Share This Page