1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Duplicate Editor bug

Discussion in 'Resolved Bug Reports' started by dutchbb, Mar 13, 2011.

  1. dutchbb

    dutchbb Well-Known Member

    Watch: http://www.youtube.com/watch?v=KhEddX-4Zbo (best full screen)

    Steps:

    1. Use Code button to insert this code:

    Code:
    Server Error
    
    Mysqli statement execute error : Data too long for column 'last_thread_title' at row 1
    
    Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
    Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
    Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 574
    Zend_Db_Adapter_Abstract->insert() in XenForo/DataWriter.php at line 1500
    XenForo_DataWriter->_insert() in XenForo/DataWriter.php at line 1489
    XenForo_DataWriter->_save() in XenForo/DataWriter.php at line 1291
    XenForo_DataWriter->save() in XenForo/Model/Import.php at line 316
    XenForo_Model_Import->_importData() in XenForo/Model/Import.php at line 685
    XenForo_Model_Import->importForum() in XenForo/Importer/vBulletin.php at line 1372
    XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1391
    XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1391
    XenForo_Importer_vBulletin->_importForumTree() in XenForo/Importer/vBulletin.php at line 1324
    XenForo_Importer_vBulletin->stepForums() in XenForo/Importer/Abstract.php at line 77
    XenForo_Importer_Abstract->runStep() in XenForo/ControllerAdmin/Import.php at line 161
    XenForo_ControllerAdmin_Import->_runStep() in XenForo/ControllerAdmin/Import.php at line 213
    XenForo_ControllerAdmin_Import->_startStep() in XenForo/ControllerAdmin/Import.php at line 156
    XenForo_ControllerAdmin_Import->actionStartStep() in XenForo/FrontController.php at line 310
    XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    XenForo_FrontController->run() in /home/****/domains/mydomain.com/public_html/****/admin.php at line 13
    2. Place mouse cursor after first line ('Server Error') and press enter.

    3. Place mouse cursor below [/CODE] and press enter.

    4. Notice that most of the content disappears.
     
  2. Ati

    Ati Active Member

    Wow. Reproduced. Interesting.
     
  3. Mike

    Mike XenForo Developer Staff Member

    This has been reported a few times now, and I am currently unable to fix it. It has to do with how the browsers handle some of the inserted HTML.
     
  4. dutchbb

    dutchbb Well-Known Member

    Oh ok, sorry for the duplicate.
     

Share This Page