1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Double Posts

Discussion in 'Troubleshooting and Problems' started by JamesBrown, Aug 28, 2015.

  1. JamesBrown

    JamesBrown Well-Known Member

    I have an increasing number of posters who double post every time.

    I don't use tapatalk
    I don't use responsive Adsense
    Minimum Time between messages set at 20sec
    Speaking to those affected, they are not on slow connections and only submit once
    Changing browsers/clearing caches makes no difference

    Any ideas? Thanks
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    You already addressed my two common guesses... Tapatalk and a slow connection.

    It could be some other addon but I have not seen any other specific reports besides Tapatalk.
     
  3. imthebest

    imthebest Formerly Super120

    Since I started using XF (1.3) I always experience double or even triple threads. It is like if someone posts a thread and then clicks on the button again so the thread gets duplicated. I believe this might be due to slow connections although I also believe that XenForo should have code to prevent these situations.

    I have to say however that I have many add-ons installed.
     
  4. AndyB

    AndyB Well-Known Member

    The members who frequently double post, are they all on a mobile devices?
     
  5. rafass

    rafass Well-Known Member

  6. The Sandman

    The Sandman Well-Known Member

    We had an issue like this on TAZ - turned out it was due to IPv6 routing issues at the datacenter interfering with one of our add-ons.
     
    Last edited: Aug 28, 2015
  7. JamesBrown

    JamesBrown Well-Known Member

    No not necessarily, It's happening to some that use mobiles, but others that are on desktops with superfast cable connections.
     
  8. karlgray

    karlgray Member

    It just happened to me. I am on a laptop and only clicked once. I am a more than competent user and know that I didn't click twice.
    First time it has happened to me and prior to this I always thought it was users being idiots and double clicking or similar.

    My post appeared 3 times, I deleted one and 2 disappeared.

    Having said that, just after it happened my browser went nuts. It dropped down from full screen on it's own My fingers were no where near the keyboard or mouse as I was rolling a ciggy. I maximised and it had opened youtube in a new tab. I closed this new tab and it un maximised again. This repeated a few times with me thinking wtf? It then closed 4 tabs that I was using and started behaving normally again. I went to history to re-open the closed tabs and they weren't present in the history list. My system is clear of Malware...

    It is possible therefore that these double/triple posts are a browser bug and not a user problem.
     
  9. AndyB

    AndyB Well-Known Member

    Same thing happened to me yesterday, exactly the same thing. I suspect it had something to do with Flash crashing, maybe in another tab.
     
  10. karlgray

    karlgray Member

    Thanks Andy, I don't have flash enabled in this browser.

    However I opened a message with Jim about it and got a duplicate message then 3 posts for the response.

    I shut down my browser and restarted it and everything cleared up. I do now suspect it is a browser related issue?
     
  11. AndyB

    AndyB Well-Known Member

    Which browser are you using? I'm using Firefox on OSX.
     
  12. karlgray

    karlgray Member

    Unfortunately I have been forced onto a windows system for a little bit so it is Windows 8.1 and Firefox 40.0.3.
    It never happened on my Linux Systems.
     
  13. Mouth

    Mouth Well-Known Member

    I too have the same issue, for the last couple of months. Haven't been able to resolve it, so will be watching this thread hopefully.
     
  14. karlgray

    karlgray Member

    I meant to say I have just moved away from ABP and now use Privacy Badger and uBlock as they are much lighter weight. I am wondering if it could be a plugin issue as these two are new to this me.
     
  15. AndyB

    AndyB Well-Known Member

    Perhaps a Firefox issue.
     
  16. JamesBrown

    JamesBrown Well-Known Member

    It's certainly not going away. Happening more and more. Someone sent me a Conversation about it this morning and that was doubled up too! #paininthearse
     
  17. king8084

    king8084 Active Member

    this is an issue with XF since it was relesed and it never been solved, the only way to stop it is to put a 5-7 secs timeout between posts...and go to user group permission and dont allow them to bypass it

    double posting will stop
     
    adwade likes this.
  18. Martok

    Martok Well-Known Member

    Rubbish. Forums with this flood check already in place are having the double post issue. Also I don't have it on my moderators group and don't get double posts.
     
  19. king8084

    king8084 Active Member

    not sure how is that rubbish when it worked for me
     
  20. Mr Lucky

    Mr Lucky Well-Known Member

    What happens even with the flood check is that the first post is actually made, but the user gets the You must wait xxx seconds notice before posting, and without the realising the first post is there, they wait and then click again so then the second post gets posted.

    You could change the phrase of that notice to tell people to ignore it unless they really did attempt two posts so quickly, and to refresh the page. This would help I think but obviously not ideal.

    Luckily I cured the problem on my site when I found it was Google after 1st post causing it.
     

Share This Page