• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Double Posts

JamesBrown

Well-known member
#1
I have an increasing number of posters who double post every time.

I don't use tapatalk
I don't use responsive Adsense
Minimum Time between messages set at 20sec
Speaking to those affected, they are not on slow connections and only submit once
Changing browsers/clearing caches makes no difference

Any ideas? Thanks
 

Jake Bunce

XenForo moderator
Staff member
#2
You already addressed my two common guesses... Tapatalk and a slow connection.

It could be some other addon but I have not seen any other specific reports besides Tapatalk.
 

imthebest

Well-known member
#3
Since I started using XF (1.3) I always experience double or even triple threads. It is like if someone posts a thread and then clicks on the button again so the thread gets duplicated. I believe this might be due to slow connections although I also believe that XenForo should have code to prevent these situations.

I have to say however that I have many add-ons installed.
 

The Sandman

Well-known member
#6
We had an issue like this on TAZ - turned out it was due to IPv6 routing issues at the datacenter interfering with one of our add-ons.
 
Last edited:
#8
It just happened to me. I am on a laptop and only clicked once. I am a more than competent user and know that I didn't click twice.
First time it has happened to me and prior to this I always thought it was users being idiots and double clicking or similar.

My post appeared 3 times, I deleted one and 2 disappeared.

Having said that, just after it happened my browser went nuts. It dropped down from full screen on it's own My fingers were no where near the keyboard or mouse as I was rolling a ciggy. I maximised and it had opened youtube in a new tab. I closed this new tab and it un maximised again. This repeated a few times with me thinking wtf? It then closed 4 tabs that I was using and started behaving normally again. I went to history to re-open the closed tabs and they weren't present in the history list. My system is clear of Malware...

It is possible therefore that these double/triple posts are a browser bug and not a user problem.
 
#10
Thanks Andy, I don't have flash enabled in this browser.

However I opened a message with Jim about it and got a duplicate message then 3 posts for the response.

I shut down my browser and restarted it and everything cleared up. I do now suspect it is a browser related issue?
 

AndyB

Well-known member
#11
Thanks Andy, I don't have flash enabled in this browser.

However I opened a message with Jim about it and got a duplicate message then 3 posts for the response.

I shut down my browser and restarted it and everything cleared up. I do now suspect it is a browser related issue?
Which browser are you using? I'm using Firefox on OSX.
 
#12
Unfortunately I have been forced onto a windows system for a little bit so it is Windows 8.1 and Firefox 40.0.3.
It never happened on my Linux Systems.
 

Mouth

Well-known member
#13
I have an increasing number of posters who double post every time.

I don't use tapatalk
I don't use responsive Adsense
Minimum Time between messages set at 20sec
Speaking to those affected, they are not on slow connections and only submit once
Changing browsers/clearing caches makes no difference

Any ideas? Thanks
I too have the same issue, for the last couple of months. Haven't been able to resolve it, so will be watching this thread hopefully.
 
#14
I meant to say I have just moved away from ABP and now use Privacy Badger and uBlock as they are much lighter weight. I am wondering if it could be a plugin issue as these two are new to this me.
 

JamesBrown

Well-known member
#16
It's certainly not going away. Happening more and more. Someone sent me a Conversation about it this morning and that was doubled up too! #paininthearse
 
#17
this is an issue with XF since it was relesed and it never been solved, the only way to stop it is to put a 5-7 secs timeout between posts...and go to user group permission and dont allow them to bypass it

double posting will stop
 

Martok

Well-known member
#18
this is an issue with XF since it was relesed and it never been solved, the only way to stop it is to put a 5-7 secs timeout between posts...and go to user group permission and dont allow them to bypass it

double posting will stop
Rubbish. Forums with this flood check already in place are having the double post issue. Also I don't have it on my moderators group and don't get double posts.
 

Mr Lucky

Well-known member
#20
What happens even with the flood check is that the first post is actually made, but the user gets the You must wait xxx seconds notice before posting, and without the realising the first post is there, they wait and then click again so then the second post gets posted.

You could change the phrase of that notice to tell people to ignore it unless they really did attempt two posts so quickly, and to refresh the page. This would help I think but obviously not ideal.

Luckily I cured the problem on my site when I found it was Google after 1st post causing it.