• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Does Google hate my forum?

John L.

Well-known member
#1
Hi Guys,

I have two forums that I have installed, working, and open to the public. I have done a few Google searches and noticed that my main forum page comes up when I search the general site name, but no posts from within the forum show up as sub-links like they used to when I had vBulletin/SEO. Any particular reason why this may be? A little confusing on my end. I have WordPress handling the main page which gets indexed fairly quickly.

http://www.bor3dgaming.com/
http://www.bor3dgaming.com/community/

Thanks for any help you can give me!
 

Brogan

XenForo moderator
Staff member
#2
I just searched for this: What’s Next For Bor3d Gaming

And the result was from the blog.
http://www.google.com/#hl=en&sugexp=ldymls&xhr=t&q=What’s Next For Bor3d Gaming&cp=29&qe=V2hhdBlzIE5leHQgRm9yIEJvcjNkIEdhbWluZyA&qesig=EKatsU1DrToqoHjuzye9Tg&pkc=AFgZ2tlYJVWLjR6zRMty4iSUnd09amKM_8hIbqS28a48lwfva_uCgFOY2HjqDjBnkkbZOr0UzcVuFZdGTSGg0hqM5mgprwosbA&pf=p&sclient=psy&aq=f&aqi=&aql=&oq=What’s Next For Bor3d Gaming &pbx=1&bav=on.2,or.r_gc.r_pw.&fp=fd1a2cf87d4138e7&bs=1

It looks like the blog content is being indexed higher than the forum content.
From what I've read, having duplicate content isn't good.

There's no doubt your WordPress home page is affecting your results in Google as I was getting excellent returns after less than a week running XenForo.
 

John L.

Well-known member
#3
I just searched for this: What’s Next For Bor3d Gaming

And the result was from the blog.
http://www.google.com/#hl=en&sugexp=ldymls&xhr=t&q=What’s Next For Bor3d Gaming&cp=29&qe=V2hhdBlzIE5leHQgRm9yIEJvcjNkIEdhbWluZyA&qesig=EKatsU1DrToqoHjuzye9Tg&pkc=AFgZ2tlYJVWLjR6zRMty4iSUnd09amKM_8hIbqS28a48lwfva_uCgFOY2HjqDjBnkkbZOr0UzcVuFZdGTSGg0hqM5mgprwosbA&pf=p&sclient=psy&aq=f&aqi=&aql=&oq=What’s Next For Bor3d Gaming &pbx=1&bav=on.2,or.r_gc.r_pw.&fp=fd1a2cf87d4138e7&bs=1

It looks like the blog content is being indexed higher than the forum content.
From what I've read, having duplicate content isn't good.

There's no doubt your WordPress home page is affecting your results in Google as I was getting excellent returns after less than a week running XenForo.
Okay, but what duplicate content would you be referring to? Do you mean because what's posted in Wordpress as apart of the blog is also being posted to XenForo via RSS? So should I just disable the RSS Feed portion and have it stop going to XenForo? But this still doesn't help me when it comes to my forum not being indexed.
 

Brogan

XenForo moderator
Staff member
#6
I wouldn't be able to comment, I've never used WordPress.

Do you have guests blocked for threads, etc?
I just tried clicking on some threads and all I see is a message.
 

Russ

Well-known member
#8
Hey jljr222 I too tried googling your site awhile back because I loved the design and integration of everything but could not find at all, I managed to track you down here on the boards somewhere but I hope you look into it! I was wanting to join in the community.
 

John L.

Well-known member
#9
Hey jljr222 I too tried googling your site awhile back because I loved the design and integration of everything but could not find at all, I managed to track you down here on the boards somewhere but I hope you look into it! I was wanting to join in the community.
Ah, yea I am thinking of ditching WordPress and letting XenForo handle everything. Will take me a little bit to get all the redirects in order, but should be fine.
 

Brogan

XenForo moderator
Staff member
#10
I guess you have Google Webmaster and Analytics accounts too?
They can be useful for analysing traffic and issues.

If you do make any major changes you'll have to wait a while for Google to re-index the site.
 

John L.

Well-known member
#11
I guess you have Google Webmaster and Analytics accounts too?
They can be useful for analysing traffic and issues.

If you do make any major changes you'll have to wait a while for Google to re-index the site.
I do, and analyzing the traffic I saw no major issues, actually an increase in traffic. I just noticed that indexing the forum was a problem when doing direct searches. And I have no worries about waiting, just another change out of a million I have done to this site.