1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Display custom userfield below username in posts?

Discussion in 'Styling and Customization Questions' started by Adam K M, Apr 13, 2013.

  1. Adam K M

    Adam K M Active Member

    Hello!
    How would I go about making my 'custom user field' display below a user's name in posts? (Like where the rank tag is)
     
  2. Andrej

    Andrej Well-Known Member

    Select the options I have highlighted in the screenshots below.

    Снимок экрана 2013-04-13 в 21.26.41.png Снимок экрана 2013-04-13 в 21.27.04.png
     
    Jake Bunce and Adam K M like this.
  3. Adam K M

    Adam K M Active Member

    Thanks for trying, but....
    I already have that all, but nothing shows up...
    On here, you should see the word "muffin" somewhere beside my post.... but you don't! :cry:
    Is there a way to make it so it does, maybe above my rank? (With special CSS too!)
     
  4. Tracy Perry

    Tracy Perry Well-Known Member

    You DID go into the custom user field and tell it to display, correct (Field Viewable in message user info).

    1.png
     
  5. Adam K M

    Adam K M Active Member

    Yep
    mcusername.PNG
     
  6. Nasr

    Nasr Well-Known Member

    Did you check the style property in the correct style as well?
     
  7. Adam K M

    Adam K M Active Member

    Yep :/

    Uh, is there a certain template I can edit manually to get it to appear?
    The "Field ID" is mcusername :)
    Thanks in advance
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    Did you inquire with the author of your style "XenFocus"?
    Can you get ANY of the additional information to show up (like the # posts, hometown, etc) that are default to be able to use? If these don't show either, then it will be a style issue - and you will need to address that with the style author.
     
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Also, do you have any outdated templates?
     
  10. Adam K M

    Adam K M Active Member

    @Brogan Yeah :/
    Would you mind explaining to me how I can go about updating them, especially if I've made changes?
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    HOW did you make changes? Direct to the template itself or via TMS. I've got a feeling you did direct edits and if so you will probably need to denote the changes you have made, revert the templates back and make sure that they are not outdated and then (my preferred method) use TMS to do your updates to your templates with.
     
  12. Steve F

    Steve F Well-Known Member

    Can you confirm if the fields are present in the default style? User Fields was introduced in XF 1.1.0 so I would assume your style should have updated templates unless something happened. What version of XF are you using?

    If you need some help I could check it out for you.
     
    Adam K M and Russ like this.
  13. Adam K M

    Adam K M Active Member

    That would be great, thanks! Going to take it all in, hopefully I'll be able to contact you over the weekend!
    The url to my website:
    Forums
    Just incase you're interested in checking it outyourself
     
  14. Steve F

    Steve F Well-Known Member

    I'll register, but will most likely need to have access to the ACP to check it all out.
     

Share This Page