Fixed 'Display children in navigation' does not work for nodes that appear after a node that does not display children

Affected version
v2.2.1

36degrees

Member

Steps to reproduce​

  1. Create 2 nodes, each with at least one child.
  2. Add a navigation item of type 'node' for the first node, with 'Display children in navigation' set to false.
  3. Add a navigation item of type 'node' for the second node, with 'Display children in navigation' set to true. Ensure that its display order is set so that it appears after the first node in the navigation.

Expected result​

The children of the second node should be included in the navigation.

Actual result​

The children of the second node are not included in the navigation.

However, the children are included in the navigation if you either:
  • swap their display order so that the second node (with 'Display children in navigation' set to true) appears first; or
  • set 'Display children in navigation' to true for both nodes
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XF release (2.2.2).

Change log:
Fix a situation where the "display children in navigation" option for node-based navigation entries does not work.
There may be a delay before changes are rolled out to the XenForo Community.
 
Top