Fixed Trying to add a note after failing to add a tag does not work

Affected version
2.1.8; also tested on xenforo.com

36degrees

Member
If you go to 'Add note/tag' the 'Tag a user' option shows first.

If you start writing your note in that box before realising your mistake and switching to 'Write a note', the username entered in the (inactive) 'Tag a user' tab prevents the note from being saved.

Steps to reproduce​

  1. Click 'Add note/tag'
  2. Type a note, or anything as long as it is not a valid username, into the box.
  3. Realise you meant to add a note, and click the 'Write a note' tab
  4. Type an actual note
  5. Press 'save'
Note: You might press 'Save' between steps 2 and 3, in which case you'd (legitimately) see the validation error before you realised that you meant to write a note instead of tagging someon.

Expected result​

The note should be saved.

Actual result​

A dialog is shown with the message 'The requested user could not be found.'
 

36degrees

Member
Also unexpected - if the username entered in step 2 is valid then the note is discarded and a tag is added instead, despite the user having entered the 'Write a note' mode.
 

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XFMG release (2.2.0 RC2).

Change log:
Make the image user tag/note UI more clear
There may be a delay before changes are rolled out to the XenForo Community.
 
Top