1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Discouraged not working . . .

Discussion in 'Troubleshooting and Problems' started by LuvMeSumZen, Feb 10, 2014.

  1. LuvMeSumZen

    LuvMeSumZen Active Member

    I have one member that I ticked as discouraged in his profile in the acp, but it isn't working on him. I did this 20 minutes ago, but he is still navigating the site with impunity. I tried it on my test account and it works fine on me. Are there OS or maybe IPs that it doesn't work on? I can't discourage his IP because it says there's no information available for his IP.
     
  2. Chris D

    Chris D XenForo Developer Staff Member

    How do you know it isn't working?

    Discouragement isn't the same as banning.

    Discouragement makes the site more difficult to use, bordering on impossible (depending on the discouragement settings). It is more than likely that it is working, but they aren't necessarily going to disappear from the site until they get fed up of the various errors they will encounter as a result of the discouragement.
     
  3. LuvMeSumZen

    LuvMeSumZen Active Member

    Chris, thanks for the reply. Yes I am familiar with what it is and how it works. I played with it extensively when I first got xf. I know it isn't working because I see him navigating the site rapidly so there is no way he is getting redirected and getting blank pages, etc. He even sent me 2 PMs within 3 minutes apart, about 15 minutes after I ticked his account. He is navigating and posting as if nothing has happened.
     
  4. DBA

    DBA Well-Known Member

    What is your minimum timeout?
     
  5. Mike

    Mike XenForo Developer Staff Member

    The change is only in 1.3 because it's fairly significant, but if you discourage a user, it caches the result in the session. 1.3 changes this to ensure the change is reflected immediately. (Applies to IP banning as well.)
     
    CyclingTribe and Divvens like this.
  6. LuvMeSumZen

    LuvMeSumZen Active Member

    Not sure what you mean Mike - I am still using 1.2
     
  7. LuvMeSumZen

    LuvMeSumZen Active Member

    Are you referring to Loading Delay? If so I have it set at 65 to 180
     
  8. Chris D

    Chris D XenForo Developer Staff Member

    Mike's basically saying that in 1.2 the discouragement may not take immediate effect. Whereas it does in 1.3.
     
  9. LuvMeSumZen

    LuvMeSumZen Active Member

    Okay I see, thanks for the clarification. It does take immediate effect with mine and 2 other of my mods test accounts though. And I also watched him cruising the forum again this morning for about 10 minutes and his activity was unencumbered - I saw him flitting around various forums with seeming immunity from the discouragement.
     

Share This Page