1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Disable xcache (or other cache) before importing

Discussion in 'Installation, Upgrade, and Import Support' started by Peace, May 3, 2016.

  1. Peace

    Peace Active Member

    Just wanted to share this, in case it saves someone else some time :)

    I've been slowly building off a vanilla xF installation, adding plugins, options, styles, phrases, etc. Getting ready for our main migration.

    Today, when I tried a test data import, it completely screwed up on Users, going back and forth between various percentages, stopping constantly, and eventually resulting in users with message count of 77,000 (who actually only had like 7,000 posts).

    I drove myself crazy trying to figure out what plugin, option, style, etc could have caused it, since the test imports were working fine a week ago.

    Finally I compared config.php and found the only change was enabling xcache, and enabling debug mode.

    After commenting out those lines, the import went totally fine, no problems at all :)

    So if you're having any trouble with an import, I definitely recommend just turning off config.php cache during the import (and then re-enable after).

    I should also add that I modified the vBulletin 4 importer limits a bit higher, trying to speed up the import process a bit. So my importer wasn't quite "out of box". But either way, disabling cache fixed the issue.
     
    Last edited: May 3, 2016

Share This Page