• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Disable requirement for 2 step verification

XenBurger

Active member
#1
1) I registered a new user account and was a little freaked out to see that the entire forum was "hidden" from view for that new user, pending their clicking the activation link in their email. I do not want to do this and I don't know where this setting is. Where can I undo this for a new registrant? They should still be able to at least view the forums.

2) I also encountered this on the basically now-blank forum page: "You must enable two-step verification to continue. Two-step verification increases the security of your account by requiring you to provide an additional code to complete the login process. If your password is ever compromised, this verification will help prevent unauthorized access to your account."

I don't remember turning this on and I don't want it on. How do I make it so that new registrants don't see this.

Thanks!
 

XenBurger

Active member
#2
Update: I did check Usergroup Permissions > Registered Users > and it is set to "Require two step verification" (not set) No already.
 

XenBurger

Active member
#3
Update: It was the permissions for 'Unregistered/Unconfirmed'. My brain was telling me "this is after registration, so this person should be in "Registered" usergroup" but apparently people who have not yet clicked the email confirmation stay in the "Unregistered/Unconfirmed" combo group.

So I disabled require two step.
And I enabled "Yes" for "View Nodes" and "View Posts" etc.

I'm still a little confused.

Because surely Google has been able to see my forums. And Google is in the "Unregistered" usergroup (Guests).

Yet someone who had just registered and not yet clicked the Email confirmation - for them - the entire forum was hidden.

Any ideas on why?