1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 disable exif rotation

Discussion in 'XenForo Questions and Support' started by andybond, Sep 29, 2014.

  1. andybond

    andybond Active Member

    is it possible to disable exif rotation for apple devices ?

    If I take a picture with the home button to the left it appears upside down. Is it possible to disable to manipulate this behavoir ?
  2. Chris D

    Chris D XenForo Developer Staff Member

    You could disable the EXIF functions in PHP, but the whole idea of EXIF rotation is it should be rotating it the correct way up. This isn't the first time I've seen someone report this.

    I'll do some testing.

    What iOS version?
  3. andybond

    andybond Active Member

    hi @Chris D

    found it occuring on iOS7.x and iOS8 and iOS8.02 so far.
  4. Chris D

    Chris D XenForo Developer Staff Member

  5. Chris D

    Chris D XenForo Developer Staff Member

    I see it's working.

    What version of XenForo? And do you have the exif functions enabled in PHP?
  6. andybond

    andybond Active Member

    Xenforo 1.4
    How can I check the EXIF functions ?
  7. Chris D

    Chris D XenForo Developer Staff Member

    In your admin CP go to the URL:


    You should see exif in there if you search the page for it:

  8. andybond

    andybond Active Member

    I didnt see that info , so I have contacted my host who is recompling the matrix ( or something like that ) for me .

    Give me wintel any day , you open source chaps speak a funny language.

    Will test after that @Chris D
    Chris D likes this.
  9. andybond

    andybond Active Member

    Working well now thanks ! :)
    Chris D likes this.
  10. BentDreams

    BentDreams Active Member

    @Chris D , sorry to revive an old topic, but I'm having issues where a lot of my Android user's images are not oriented correctly. I've looked at the EXIF data of a few of them and it's because the pixels are reported backwards for orientation, but everything I've found other than this post involve hacking the core files and then redoing the hack everytime an update is released which I'd really rather not do.

    Does this avoid that now in 1.4.x?

    Either way, for some reason when I go to that URL for my site it just displays the ACP tools page menu without any CSS applied to it.
    Last edited: Sep 29, 2015

Share This Page