1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Digitalpoint CSS Disappeared

Discussion in 'Off Topic' started by Donny, Mar 31, 2015.

  1. Donny

    Donny Active Member

  2. Lee

    Lee Well-Known Member

    Fine here.
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    Posting on the site in question or using the contact form would be a more appropriate thing to do.
     
  4. Donny

    Donny Active Member

    Seems I've fell into his "not the perfect user mitigation system" perhaps.

    :LOL::LOL::LOL::LOL:

    Not particularly wishing to help fix the issue, if it is one, I was merely wondering whether it was just my system or perhaps a cache issue my end.
     

    Attached Files:

  5. digitalpoint

    digitalpoint Well-Known Member

    Someone else reported it... and from testing with them, it seemed to be an issue with their ISP (Virgin Media UK). My best guess is that they have a caching system in place on their network that is mucked. That user was able to toggle between Virgin Media and another ISP and it was only an issue when on Virgin Media, and the underlying HTTP requests were never actually getting to our server.
     
  6. AdamD

    AdamD Well-Known Member

    Yea, Virgin media has their own caching servers, doesn't always work too well for end users though.
     
    MattW likes this.
  7. RickM

    RickM Well-Known Member

    If it helps, I'm on Virgin Media and DP loads perfectly fine. I don't however use their internal DNS as it's crap. I always just stick Googles 8.8.8.8 / 8.8.4.4 nameservers in my router config.
     
  8. digitalpoint

    digitalpoint Well-Known Member

    Just out of curiosity, if you switch to their DNS, do you get the same issue? Maybe their caching system is DNS based.
     
  9. AdamD

    AdamD Well-Known Member

  10. RickM

    RickM Well-Known Member

    Nope, still loads fine here. Works fine on three (mobile network) too.
     
  11. digitalpoint

    digitalpoint Well-Known Member

    Super fun trying to debug something that you can't see yourself. hah
     
  12. Liam W

    Liam W Well-Known Member

    I had this myself, on my mobile internet (I tether normally).

    It fixed itself the next time I visited though...

    I'm on Three.
     
  13. Sador

    Sador Well-Known Member

    To make it a bit more interesting: I have the same issue, but only on FireFox, Chrome an IE are fine. So that does seem to point to a cache issue (as I only occasionally visit your site and only on FireFox), although I've never had the issue before. However, I'm not using Virgin Media, I'm not even in the UK at all. Also, I've never had any issues on any other websites.
     
  14. digitalpoint

    digitalpoint Well-Known Member

    I think I finally sorted out what the issue was for some users. If anyone is still seeing it happen, please let me know.

    It had to do with CloudFlare's security settings inadvertently set way too high on the domain I use for static content (dpstatic.com), meaning a user could get to digitalpoint.com, but when they tried to access content from dpstatic.com, the system was presenting them with a captcha to solve. Which of course doesn't work really well when the content being accessed is something embedded like CSS, JavaScript, images, etc. (which is all that domain is for). The net result being the user never sees the captcha to solve and they also don't get the content (like the CSS file).

    That also explains why it was happening to some users, but not others. Basically just happening to users that CloudFlare thinks are possibly "bad actors" based on IP, HTTP headers or whatever else.
     
    Daniel Hood, AdamD and Liam W like this.
  15. AdamD

    AdamD Well-Known Member

    Cloudflare probably knows how awful Virgin media is as an ISP, lol.
     
    SneakyDave likes this.
  16. Sador

    Sador Well-Known Member

    Seems solved for me.

    That said, it's interesting that cloudflare has issues with one browser but not the other (using the same IP etc.).
     
  17. erich37

    erich37 Well-Known Member

    when I visit your website, I do not see any CSS.
    I also do get a Virus-warning from my "G-Data" Antivirus-program (Kaspersky).
     
  18. digitalpoint

    digitalpoint Well-Known Member

    No clue on that one... :)
     

Share This Page