• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Debug Mode - what to look for?

RobParker

Well-known member
#1
We're still seeing a poor performance from XF and I was wondering if it was possible to use debug mode to see if any of the addons we use we're causing issues.

Could someone maybe explain some of the things returned via debug mode? For example, what's the "params" value? Some of the numbers returned there are very high.
 

Jake Bunce

XenForo moderator
Staff member
#2
You can enable debug mode by adding this line to your library/config.php file:

Code:
$config['debug'] = 1;
It will show load stats at the bottom of every forum page which is a good way to see if an addon is affecting load in any way. Simply compare the load numbers at the bottom of the page with and without an addon enabled.
 

RobParker

Well-known member
#3
Sorry I wasn't clear. I have debug mode enabled but it's not clear what some of the output means, such as:

Params: 347, 347, 1333807787
Run Time: 0.000907

What's the params values there?
 

RobParker

Well-known member
#4
Another example is

Code:
INSERT INTO xf_session_activity
	(user_id, unique_key, ip, controller_name, controller_action, view_state, params, view_date)
VALUES
	(?, ?, ?, ?, ?, ?, ?, ?)
ON DUPLICATE KEY UPDATE
	ip = VALUES(ip),
	controller_name = VALUES(controller_name),
	controller_action = VALUES(controller_action),
	view_state = VALUES(view_state),
	params = VALUES(params),
	view_date = VALUES(view_date)
Params: 347, 347, 1396923388, XenForo_ControllerPublic_Index, Index, valid, , 1336399898
Run Time: 0.000489
 

Jeremy P

Well-known member
#5
They correspond to the values being inserted..
Code:
(user_id, unique_key, ip, controller_name, controller_action, view_state, params, view_date)
(347, 347, 1396923388, XenForo_ControllerPublic_Index, Index, valid, , 1336399898)