• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Datas must be string or set automatic_serialization = true

Status
Not open for further replies.

Stuart Wright

Well-known member
#1
We're getting server errors every few minutes:
Zend_Cache_Exception: Datas must be string or set automatic_serialization = true - library/Zend/Cache.php:209
Generated By: Unknown Account, 9 minutes ago
Stack Trace
#0 /home/sites/avforums/public_html/library/Zend/Cache/Core.php(360): Zend_Cache::throwException('Datas must be s...')
#1 /home/sites/avforums/public_html/library/DigitalPointBetterAnalytics/Model/Analytics.php(284): Zend_Cache_Core->save(false, 'analytics_realt...', Array, 3600)
#2 /home/sites/avforums/public_html/library/DigitalPointBetterAnalytics/CronEntry/Cron.php(15): DigitalPointBetterAnalytics_Model_Analytics->getRealtimeUsage()
#3 [internal function]: DigitalPointBetterAnalytics_CronEntry_Cron::runVeryOften(Array)
#4 /home/sites/avforums/public_html/library/XenForo/Model/Cron.php(357): call_user_func(Array, Array)
#5 /home/sites/avforums/public_html/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
#6 /home/sites/avforums/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 7.9773111343384, '')
#7 /home/sites/avforums/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.9773111343384, '', false)
#8 /home/sites/avforums/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#9 /home/sites/avforums/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#10 {main}
Request State
array(3) {
["url"] => string(37) "https://www.avforums.com/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(106) "/threads/acrylic-platter-and-record-clamp-for-project-debut-carbon-also-added-project-phono-box-s.1981615/"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}
Where should I look to track down the problem, please?
 

Mike

XenForo developer
Staff member
#3
It has absolutely nothing whatsoever to do with that...

It's from the better analytics add-on. It appears to require automatic serialization to be enabled in your cache config. You should contact the author.
 
Status
Not open for further replies.