• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Database error after removing a member.

Glockie

Well-known member
#1
Hello all,
Had a peculiar situation last night and to this morning.

I deleted a member on their request, and a few hours later a thread that this person had replied to, wouldn't load and had database errors on it.

Now I'm not very good with analysing things like this.
I've since disabled addons and re-enabled them and it's cleared.

Just wondering if anyone would know what would trigger this?
What's worrying me, is if I delete others' will the same happen again?
I don't really know where to start if I am honest with errors like these.

Hope someone can pinpoint to what the issue is.
many thanks!

PS, when deleting a member, is it necessary to then remove everything related to them, from the database?

Code:
Zend_Db_Statement_Mysqli_Exception: Mysqli prepare error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1 - library/Zend/Db/Statement/Mysqli.php:77
Generated By: Admin, 8 minutes ago
Stack Trace

#0 //public_html/library/Zend/Db/Statement.php(115): Zend_Db_Statement_Mysqli->_prepare('Select COUNT(re...')
#1 //public_html/library/Zend/Db/Adapter/Mysqli.php(381): Zend_Db_Statement->__construct(Object(Zend_Db_Adapter_Mysqli), 'Select COUNT(re...')
#2 //public_html/library/Zend/Db/Adapter/Abstract.php(478): Zend_Db_Adapter_Mysqli->prepare('Select COUNT(re...')
#3 //public_html/library/Zend/Db/Adapter/Abstract.php(825): Zend_Db_Adapter_Abstract->query('Select COUNT(re...', Array)
#4 //public_html/library/UserRecommendation/Xenforo/Model/Recommend.php(57): Zend_Db_Adapter_Abstract->fetchOne('Select COUNT(re...')
#5 //public_html/library/UserRecommendation/Listener.php(71): UserRecommendation_Xenforo_Model_Recommend->getRecommendationsCount(NULL)
#6 [internal function]: UserRecommendation_Listener::templateCreate('user_banner_pos...', Array, Object(XenForo_Template_Public))
#7 //public_html/library/XenForo/CodeEvent.php(58): call_user_func_array(Array, Array)
#8 //public_html/library/XenForo/Template/Abstract.php(82): XenForo_CodeEvent::fire('template_create', Array, 'user_banner_pos...')
#9 //public_html/library/XenForo/Template/Abstract.php(105): XenForo_Template_Abstract->__construct('user_banner_pos...', Array)
#10 //public_html/library/UserRecommendation/Listener.php(48): XenForo_Template_Abstract->create('user_banner_pos...', Array)
#11 [internal function]: UserRecommendation_Listener::templateHook('message_user_in...', '???????????????...', Array, Object(XenForo_Template_Public))
#12 //public_html/library/XenForo/CodeEvent.php(58): call_user_func_array(Array, Array)
#13 //public_html/library/XenForo/Template/Abstract.php(285): XenForo_CodeEvent::fire('template_hook', Array, 'message_user_in...')
#14 //public_html/library/XenForo/Template/Abstract.php(265) : eval()'d code(1653): XenForo_Template_Abstract->callTemplateHook('message_user_in...', '???????????????...', Array)
#15 //public_html/library/XenForo/Template/Abstract.php(265): eval()
#16 //public_html/library/XenForo/Template/Abstract.php(191): XenForo_Template_Abstract->_renderInternal('$__output = '';...', Array)
#17 //public_html/library/XenForo/Template/Public.php(110): XenForo_Template_Abstract->render()
#18 //public_html/library/XenForo/ViewRenderer/HtmlPublic.php(123): XenForo_Template_Public->render()
#19 //public_html/library/XenForo/FrontController.php(618): XenForo_ViewRenderer_HtmlPublic->renderContainer(Object(XenForo_Template_Public), Array)
#20 //public_html/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_HtmlPublic), Array)
#21 //public_html/index.php(13): XenForo_FrontController->run()
#22 {main}

Request State

array(3) {
  ["url"] => string(72) "http://myurl.com/threads/thread-title/"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}
 

Glockie

Well-known member
#3
Yes you are right.. I just created a dummy thread, and deleted the account. same issue occurred.
Thanks I will speak with the dev.

Many thanks