D.C Style - Thumbnail

D.C Style - Thumbnail 1.0.2 Patch Level 4

No permission to download

beerForo

Well-known member
Bug
The thumbnail slightly covers the thread title on small screens (phone). To test on computer you can minimize your window and you will see it. I can also send a screenshot via PM.
 

nicodak

Well-known member
Hello, thanks for this great free add-on @D.C Style !
Just 2 questions :
  • If a member chooses to upload a custom image of, for example, 2 MB and 3000 x 2000px, what exactly happens? is the image resized or not?
  • Could the add-on create a thumbnail from an embedded image from the gallery? That would be great !
Thank you very much !!
 

oO5 Dynasty

Well-known member
Having an issue, where the default thumbnail is not showing. I did all the caching but the only way I can see a thumbnail is if I upload an attachment.
Web capture_21-7-2022_13251_user.oo5dynasty.com.jpegWeb capture_21-7-2022_132948_user.oo5dynasty.com.jpeg

When I go into the edit thumbnail option it is showing my image as missing.
 

voom

Member
I activated the thumbnails only for two nodes. On all other nodes, the button to add a thumbnail is shown anyway, if someone is permitted to add one. If an image is uploaded that way, it does not show. This might be irritating to the users.

In dcThumbnail_append_thumbnail_edit_button there is only <xf:if is="$thread.canEditThumbnail()"> where the button is to be shown. There does not seem to be an "if" for hiding it in the forums not selected in the options.

Probably there should be: <xf:if is="$thread.getThumbnail()"> as well....
 
Last edited:

D.C Style

Well-known member
Having an issue, where the default thumbnail is not showing. I did all the caching but the only way I can see a thumbnail is if I upload an attachment.
View attachment 271216View attachment 271217

When I go into the edit thumbnail option it is showing my image as missing.

I activated the thumbnails only for two nodes. On all other nodes, the button to add a thumbnail is shown anyway, if someone is permitted to add one. If an image is uploaded that way, it does not show. This might be irritating to the users.

In dcThumbnail_append_thumbnail_edit_button there is only <xf:if is="$thread.canEditThumbnail()"> where the button is to be shown. There does not seem to be an "if" for hiding it in the forums not selected in the options.

Probably there should be: <xf:if is="$thread.getThumbnail()"> as well....

Thanks for the reports. An update will be released soon.
 

securedme

Active member
I'm using https://xenforo.com/community/threads/auto-thread-thumbnail-by-xenbros-deleted.154559/

It works good but the developer seems to have stopped updating it so I seek another solution that I'm lucky to have found your add-on.

It looks as good if not better as the add-on I'm using. One major problem is that it lacks local customization per node.

In Auto Thread Thumbnail that I'm using now, the add-on adds the following fields in each node so I can additionally customize the dimensions and default thumbnail for each node other than the default one in the add-on's Option.

1659491674521.png

Another problem, what's the size of the thumbnails showing in thread lists? Will it slows down the loading substantially?

Thanks.
 
Top