D.C Style - Thumbnail

D.C Style - Thumbnail 1.0.2 Patch Level 2

No permission to download

Epi

Active member
I set the maximum URL length to 255 so maybe that caused the issue. You should try to replace the long URL image with a shorter one.
Anyway, I'm looking for a solution to this problem.

I changed it to 2550 to test quick and it works now, maybe changing to LONGTEXT would fix it also?
Can't really control the length of an Image url i think.
Anyways thanks for pointing where the problem was.
 

Epi

Active member
Something weird happens for me when I enable this plugin and try to click on a pagination link in a forum's thread list. It keeps loading endlessly.
No idea why but it only happens when this addon is enabled and only on some thread list pages.
 
Last edited:

D.C Style

Well-known member
Something weird happens for me when I enable this plugin and try to click on a pagination link in a forum's thread list. It keeps loading endlessly.
No idea why but it only happens when this addon is enabled and only on some thread list pages.
Can I see your Server Errors Log?
 
  • Like
Reactions: Epi

Epi

Active member
Can I see your Server Errors Log?

Sorry for the late reply, it's not an error but when there is a thumbnail of a youtube video in the thread list it takes pretty long to load, like 65 seconds.
When I removed the thread with the youtube thumbnail it loads faster.

1601039652509.png
 

MichaelR

Member
I am looking forward to the 2.2 version to. I do wonder how the page loading speed will be with the YouTube thumbnail turned on. Do you have a demo?
 

ddmmh

Well-known member
I am looking forward to the 2.2 version to. I do wonder how the page loading speed will be with the YouTube thumbnail turned on. Do you have a demo?
I am not a coder by any means, but I am guessing it will fetch and cache a thumbnail straight up so it loads locally. Even if it doesn't, YouTube is so damn fast it will probably almost never matter :)
 

NandorHUN

Active member
Is there anything like that for forums as well?

I want to put a picture inside of a category forum as well, not just a thread. If not possible, is there an ad-on that does this?

Basically my forum look like this:

X Category / Y Forum / Z Thread

Other than Z Thread I want to put the picture the same way in Y Forum as well...
 

NandorHUN

Active member
Is it possible to automatically set any (and any new and created) threads the same picture in a forum or in a category ?
 

NandorHUN

Active member
Is it possible to set the default "no picture" to the default theme's icon?
And the default read - undread icon set?
(So that it shows different icon for unread - as it should). ?

Thanks.
 

NandorHUN

Active member
How do I add Thumbnails ? It say error to link every single time for the url... I tried internal urls and even png and jpg and other formats....
What's wrong with it?
 

NandorHUN

Active member
It's unuseable in dark themes:
How can I change the filed around the image? It's pretty much unusuable in dark themes, because the title gets white and the background is white as well....
I can set the title only with other colors so can change it separately, but the best solution would be if I can change the background color in "Gradient" mode:
 

Attachments

  • 2020.12.13 1.png
    2020.12.13 1.png
    846.4 KB · Views: 20
  • 2020.12.13 2.png
    2020.12.13 2.png
    558.2 KB · Views: 18
  • 2020.12.13 3.png
    2020.12.13 3.png
    599.1 KB · Views: 21
Last edited:

beerForo

Well-known member
PS. I plan to use it in a Suggestion type forum, if that does not work, I would like to suggest it please. Thanks!
 
Last edited:

El Porcharo

Active member
Looks like I can't make it use my custom "no image" thread...
I see in the page source code that it keeps searching for the default one.

I'm on ThemeHouse iO and iO Dark Mode styles
 

El Porcharo

Active member
no way to fix it... I've even tried setting a CSS rule in extra.less but it is ignored as the wrong URL is in the IMG element code on page.

Anyone with the same issue?


1617560804188.png
 
Top