[cv6] Custom Field Extension

[cv6] Custom Field Extension 1.1.0 Release Candidate 2

No permission to download

Hoffi

Well-known member
So, you want to have a Calculation on Ressource Level with Fields from Reviews and on amount of Reviews?

At the Moment this is Not possible. Will think of that is doable.
 

Robert9

Well-known member
I miss an option (for all custom fields):
- dont show it nowhere

Because when i want to show data from custom fields somewhere else with custom work, i also have to avoid showing it like normal.
An option to not show it would be nice, escpecially for an image.
 
Last edited:

Hoffi

Well-known member
I miss an option (for all custom fields):
- dont show i nowhere

Because when i want to show data from custom fields somewhere else with custom work, i also have to avoid showing it like normal.
An option to not show it would be nice, escpecially for an image.
You can do this on a bit quirky way. Just enter something in the Template Fields, and don't include any variable.
 

Hoffi

Well-known member
To be more specific.
Go to the wrapper HTML Template and enter something like this.
HTML:
<div style="display: none;"></div>
 

Hoffi

Well-known member
Yes, i can. But why i have to?
This option should be for all fields as standard, i guess.
To be honest, I don't see this. It can be done very easily and it's an edge case. You can do what you want to achieve with a pretty small amount of work.
And with 10 min more, you can define a class which steer the visibility on different pages differently.
 

Radikus

Member
For some reason this add-on disabled the ability to add pictures on old threads (on just the first original post).

Also I can't even uninstall this anymore.
 

Hoffi

Well-known member
For some reason this add-on disabled the ability to add pictures on old threads (on just the first original post).

Also I can't even uninstall this anymore.
Do you use the deafult style? Was it the first post, or any other post?

Posted a combo, got this error: 'A server error occurred. Please try again later.'
Can you pleas post the Error which then should be visible in the AdminCP Log, then I can dive into this Issue.
 

securedme

Active member
Do you use the deafult style? Was it the first post, or any other post?


Can you pleas post the Error which then should be visible in the AdminCP Log, then I can dive into this Issue.

Code:
ErrorException: [E_WARNING] Array to string conversion src/XF/Search/IndexRecord.php:24
Generated by: beta Aug 2, 2022 at 11:58 PM
Stack trace
#0 src/XF/Search/IndexRecord.php(24): XF::handlePhpError(2, '[E_WARNING] Arr...', '/home/nginx/dom...', 24)
#1 src/XF/Search/IndexRecord.php(48): XF\Search\IndexRecord->__construct('thread_field', 762, '', Array, 1659455928, 3, 153, Array)
#2 src/addons/AL/FilterFramework/Search/Data/BaseFieldIndexSearchData.php(93): XF\Search\IndexRecord::create('thread_field', 762, Array)
#3 src/XF/Search/Search.php(39): AL\FilterFramework\Search\Data\BaseFieldIndexSearchData->getIndexData(Object(AL\ThreadFilter\Entity\ThreadFieldIndex))
#4 src/XF/Behavior/Indexable.php(48): XF\Search\Search->index('thread_field', Object(AL\ThreadFilter\Entity\ThreadFieldIndex), false)
#5 src/XF.php(377): XF\Behavior\Indexable->XF\Behavior\{closure}()
#6 src/XF/Mvc/Dispatcher.php(158): XF::triggerRunOnce(true)
#7 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#8 src/XF/App.php(2352): XF\Mvc\Dispatcher->run()
#9 src/XF.php(524): XF\App->run()
#10 index.php(20): XF::runApp('XF\\Pub\\App')
#11 {main}

Seems it clashes with https://xenforo.com/community/resources/thread-filter-by-addonslab.6034/

I disabled it and your add-on works without errors.
 
Last edited:

Hoffi

Well-known member
Yea, thats possible, because it also handles with Custom Fields.

I am not able to fix this, I don't owe a lilcense for that, :(
 

securedme

Active member
Also, enabling this add-on will disable the image insertion by image drop when editing the message:

1659459090417.png

only URL is available.
 

securedme

Active member
The following error appears when I'm trying to uninstall this add-on. It can't be uninstalled.

Code:
XF\Db\Exception: MySQL statement prepare error [1146]: Table 'aba.xf_rm_resource_field' doesn't exist in src/XF/Db/AbstractStatement.php at line 230
XF\Db\AbstractStatement->getException() in src/XF/Db/Mysqli/Statement.php at line 198
XF\Db\Mysqli\Statement->getException() in src/XF/Db/Mysqli/Statement.php at line 41
XF\Db\Mysqli\Statement->prepare() in src/XF/Db/Mysqli/Statement.php at line 56
XF\Db\Mysqli\Statement->execute() in src/XF/Db/AbstractAdapter.php at line 96
XF\Db\AbstractAdapter->query() in src/XF/Db/AbstractAdapter.php at line 177
XF\Db\AbstractAdapter->fetchPairs() in src/addons/cv6/CustomFields/Setup.php at line 108
cv6\CustomFields\Setup->uninstallStep2() in src/XF/AddOn/StepRunnerUninstallTrait.php at line 61
cv6\CustomFields\Setup->uninstallStepRunner() in src/XF/AddOn/StepRunnerUninstallTrait.php at line 28
cv6\CustomFields\Setup->uninstall() in src/XF/Admin/Controller/AddOn.php at line 657
XF\Admin\Controller\AddOn->actionUninstall() in src/XF/Mvc/Dispatcher.php at line 352
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 259
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 115
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 57
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2352
XF\App->run() in src/XF.php at line 524
XF::runApp() in admin.php at line 13
 

Hoffi

Well-known member
Code:
ErrorException: [E_WARNING] Array to string conversion src/XF/Search/IndexRecord.php:24
Generated by: beta Aug 2, 2022 at 11:58 PM
Stack trace
#0 src/XF/Search/IndexRecord.php(24): XF::handlePhpError(2, '[E_WARNING] Arr...', '/home/nginx/dom...', 24)
#1 src/XF/Search/IndexRecord.php(48): XF\Search\IndexRecord->__construct('thread_field', 762, '', Array, 1659455928, 3, 153, Array)
#2 src/addons/AL/FilterFramework/Search/Data/BaseFieldIndexSearchData.php(93): XF\Search\IndexRecord::create('thread_field', 762, Array)
#3 src/XF/Search/Search.php(39): AL\FilterFramework\Search\Data\BaseFieldIndexSearchData->getIndexData(Object(AL\ThreadFilter\Entity\ThreadFieldIndex))
#4 src/XF/Behavior/Indexable.php(48): XF\Search\Search->index('thread_field', Object(AL\ThreadFilter\Entity\ThreadFieldIndex), false)
#5 src/XF.php(377): XF\Behavior\Indexable->XF\Behavior\{closure}()
#6 src/XF/Mvc/Dispatcher.php(158): XF::triggerRunOnce(true)
#7 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#8 src/XF/App.php(2352): XF\Mvc\Dispatcher->run()
#9 src/XF.php(524): XF\App->run()
#10 index.php(20): XF::runApp('XF\\Pub\\App')
#11 {main}

Seems it clashes with https://xenforo.com/community/resources/thread-filter-by-addonslab.6034/

I disabled it and your add-on works without errors.
I am not sure If I can handle this. The other AddOn introduces the Indexable behavior on the fields entities.
And he need to add/change the bahvior for the new field types.
 
Top