1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cursor Arrow keys problem when adding comment

Discussion in 'Troubleshooting and Problems' started by OwenJames, May 15, 2013.

  1. OwenJames

    OwenJames Active Member


    I searched, but could not find anything about this problem, so I am making a new thread. Sorry if it has been posted before, but I could not locate anything.

    Right, here is the problem.

    When a user disables "Use the rich text editor to create and edit messages" in Browsing Preferences and in doing so sets the default comment input to BBCode, the up and down cursor keys stop working. This only occurs in the comment box directly on the forum page, and not in any other instances of the comment box. When "Use the rich text editor to create and edit messages" is re-enabled, the problem goes away.

    Anyone know how to fix this, as it is annoying some of my members!

    Thanks in advance.
  2. Mike

    Mike XenForo Developer Staff Member

    I can't reproduce this and I don't see how it's really possible (without some very dodgy JS). It's just a regular <textarea>.
  3. OwenJames

    OwenJames Active Member

    Right, yeah, I have tried to replicate it right here, and I can't do it either. Weird. Obviously you won't know what I have been doing to my forum to cause this, but would it be possible something I have added (an add-on, or whatever) is causing this?

    Thanks for the reply.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Disable all add-ons and try again.

    If you have added any additional JS to the templates, remove that too.
  5. OwenJames

    OwenJames Active Member

    Thanks for the advice. I will work through, disabling the addons systematically and see which one is possibly the culprit.

    Great, quick responses on this forum. Great stuff, thanks!
  6. Brogan

    Brogan XenForo Moderator Staff Member

    If you want to disable them all quickly, edit the library/config.php file and add the following:
    $config['enableListeners'] = false;
  7. OwenJames

    OwenJames Active Member

    OK I will give that a go quickly. If that does fix it, is there a way to then go through the addons I have, turning them back on one by one to see which one is the offending member?
  8. Brogan

    Brogan XenForo Moderator Staff Member

    You will have to remove that line, manually disable each one and re-test.
  9. OwenJames

    OwenJames Active Member

    OK, your suggestion did fix the issue, so I will not go through and disable things one by one to find the problem addon. Great help, thank you!

Share This Page