• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Cron tasks not working

#1
Hi,

I have a new website with 13 members on my forum.

I only have one user group promotion actually. When new members register on my forum, they need to fill out a form to introduce themselves. When the form is filled, a new thread is created in the forum. That's where the user group promotion comes in : whenever a member has at least 1 message, he is added to a custom group I made called " Verified members "

It worked perfectly for approx. 48 hours and then, it suddenly stopped working by itself. I tried executing it manually and it worked one time. I thought I was not waiting enough time to let the cron tasks run so I stopped worrying about it.

2 days later, I realize that, even if my members filled out their introduction form, they are not in the group : " Verified members ". I tried settings the criterias to the bare minimum and executing the task manually, and it's not working at all... Even my newest member is not showing the good member ( I tried running the task manually too )

Edit: I also tried disabling every addon I had, but no success.

Can you please help me ? ( I don't know anything about cron tasks, I don't know if it is a server related or software related issue. )

Nicolas
 

Jake Bunce

XenForo moderator
Staff member
#2
Is the "Next Run" time in the future?

Admin CP -> Tools -> Cron Entries -> User Group Promotions

Promotions are run hourly. You may wish to manually run the cron after creating the promotion:

Admin CP -> Tools -> Cron Entries -> User Group Promotions -> Controls: Run

And even if you manually run the cron it only processes users who have been active in the last 3 days.
 
#3
Yes, every " Next run " times are in the future and I also tried to run the cron entries manually.

I also tried removing a member who posted something today ( to make sure he was active ) and who was previously promoted by the cron entry then running the cron entries manually but it did nothing.

When you click " Run " on a cron entry, is there any kind of delay ? Whenever I click Run, there is no delay, the page instantly switch to another page saying :
Cron entry was run successfully.