• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Creating my own Drop down Menu;

#1
Sometime ago I was able to create my own drop down menu as if you scroll over 'Forums' you'd get a drop down menu to more links to click on.
I didn't use any Add-ons or anything, I just simply used code.
I was wondering if anyone could tell me what I need to do?
Like where to add the code and what code to add and how to add more links to the drop down menu and also have the links in the drop down menu if you scroll over them they have links to them to.
Example in a Drop Down Menu:
Essentials. (Tab Name)
Vote (A name in the drop down menu.)
Vote 1 (A sublink to vote
Vote 2 (A sublink to a different voting site
Vote 3 (Another different sublink to a voting site.)
Donate (Another name
Donate 1 (A sub link to Donate
Donate 3 (a sub link to donate
Google (Another name
Help (Another name.
If needed, I'll use a Add-On.
 

Chris D

XenForo developer
Staff member
#4
I tried using that one and it said something about the .xml not being correct or something.
That's unusual, perhaps you made a mistake when uploading the files, or tried to install using the wrong XML file.

Try again, following the instructions provided, then if you still have problems post the exact error message and I'll be able to give you some advice.
 
#5
That's unusual, perhaps you made a mistake when uploading the files, or tried to install using the wrong XML file.

Try again, following the instructions provided, then if you still have problems post the exact error message and I'll be able to give you some advice.
ERROR: The files associated with this add-on could not be found. Please upload them and try again.
Is my error, where do I put what files and so froth?
I did as said on the thread, but it's not working.
 

Chris D

XenForo developer
Staff member
#6
You've definitely uploaded the files incorrectly.

Try these instructions instead. Slightly different but the result is the same.
  1. In the Nodes As Tabs download there is a folder called upload.
  2. In that folder is a folder called library.
  3. In that folder is a folder called NodesAsTabs.
  4. The NodesAsTabs folder needs to be put into your library folder on your server.
 
#7
You've definitely uploaded the files incorrectly.

Try these instructions instead. Slightly different but the result is the same.
  1. In the Nodes As Tabs download there is a folder called upload.
  2. In that folder is a folder called library.
  3. In that folder is a folder called NodesAsTabs.
  4. The NodesAsTabs folder needs to be put into your library folder on your server.
Thank you, it now works.
That was more easy to understand than what was posted on the thread.
 
#8
You've definitely uploaded the files incorrectly.

Try these instructions instead. Slightly different but the result is the same.
  1. In the Nodes As Tabs download there is a folder called upload.
  2. In that folder is a folder called library.
  3. In that folder is a folder called NodesAsTabs.
  4. The NodesAsTabs folder needs to be put into your library folder on your server.
Meh. . .it's not necessarily letting my click on the Add-On to edit new Tabs and such.
 

Jake Bunce

XenForo moderator
Staff member
#9
Meh. . .it's not necessarily letting my click on the Add-On to edit new Tabs and such.
Once Nodes As Tabs is installed you need to go to your:

Admin CP -> Applications -> Display Node Tree

Edit or create new nodes. The addon adds tab options when adding / editing a node.