Fixed Create album with embedded media

Oblivion Knight

Well-known member
Affected version
Either I'm an idiot, or this is a bug.. 😅

1.) Attempt to create a personal album
2.) Select to embed media

Result = You do not have permission

XFMG: Album permissions
Create new album - Yes
Embed media in album - Yes


XenForo developer
Staff member
Looks like a regression from this fix:



Well-known member
Found this error today myself when trying to add an embed YT video-only album. Had to upload a photo, then video, and then go back and delete the photo as a workaround.

XF Bug Bot

XenForo bug fixer bot
Staff member
Thank you for reporting this issue, it has now been resolved. We are aiming to include any changes that have been made in a future XFMG release (2.2.3).

Change log:
Fix regression that may have prevented adding embeds to a new personal album.
There may be a delay before changes are rolled out to the XenForo Community.

oO5 Dynasty

Well-known member
I just ran into a problem, when trying to embed a video into Create personal album
You do not have permission to view this page or perform this action.
So I checked permissions, and everything is set for me to be able to embed media.
So I tried to Embed media into a random category (YouTube Sports) and I was able to do so just fine.
So I tried to embed the same YouTube video into Add media to existing album and that worked.
I was even able to upload a photo to Create personal album.
I also do not remember changing any permissions dealing with the XFMG in a while.
I also disabled all add-ons and just left XFMG on and still got the error.
I have my user groups set up as such.
All members become registered members when they finish the registration process.
But only Premium + members have the permission to use XFMG.
My admin account does have Premium + as a secondary group.
So I am totally confused as to what to do lol.