1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Couldn't upgrade without error and now can't reinstall...

Discussion in 'Installation, Upgrade, and Import Support' started by Jamie, Oct 22, 2010.

  1. Jamie

    Jamie Well-Known Member

    Ok, I was running Beta 1 and downloaded Beta 2, FTP'ed the files overwriting them and ran the install file.

    It came up with an error during the Phrases part of the install. I couldn't get past that so I deleted the entire directory where xenforo was installed, created the directory again, uploaded the files again and ran the installer.

    This time it prompted me to delete the tables in the database which I checked for it to do and still it came up with an error.

    Now, I have deleted the xenforo directory again, deleted the database and recreated them both, uploaded the files and still I can't get past the phrases without running into an error.

    When it hits an error like this, is there a log file anywhere? It tells me to click the button to go back, but it doesn't present a button. Clicking the browsers back button attempts to run the installer again with the same error.

    Very weird, very frustrating because I had it installed before.. This is a test site, so I am not worried, I just don't know what to try next.

    Help tips or help with this?

    Jamie
     
  2. Blandt

    Blandt Well-Known Member

    You could check the server log, and the php log

    OS distro and the server ?
     
  3. Jamie

    Jamie Well-Known Member

    I'll check the php logs. I am on a host called FutureQuest and they don't offer a cPanel like most people have, so I will have to see what they offer in the way of logging and troubleshooting.

    Jamie
     
  4. Blandt

    Blandt Well-Known Member

    yep ... email your host because the location of the log files depends on the distro and server you are running.
     
  5. Jamie

    Jamie Well-Known Member

    My php log had no errors in it, however in looking through the database using phpMyAdmin I found this entry in the xf_error_log table:

    xferror.png

    I don't know what it means though.. :eek:

    Jamie
     
  6. Blandt

    Blandt Well-Known Member

    Neither do I :D I think Mike will have an answer here ...
     
  7. Jamie

    Jamie Well-Known Member

    ok, thanks for trying! A+ for effort. :)
     
  8. Blandt

    Blandt Well-Known Member

    But you know .. it's showing the user id to be NILL, that could throw MySQL in an error if the table is set to not accept nill values...
    That could be the reason why the script hangs hmmm ... just a thought
     
  9. Jamie

    Jamie Well-Known Member

    I would think it's doing that because it's a brand new install. Right now, until I get it installed and set the admin account, there isn't a user id is there?

    Since I got hung up on an error when I tried to go from Beta 1 to Beta 2 I deleted everything and am starting over from scratch.

    Just thinking out loud with you...

    Jamie
     
  10. Blandt

    Blandt Well-Known Member

    try dropping the whole db recreate a new one and try the install again.
    if it fails, take a look at the phpmyadmin again ....
     
    Jamie likes this.
  11. Jamie

    Jamie Well-Known Member

  12. Jamie

    Jamie Well-Known Member

    Ok, this time it stopped with the error screen, but didn't create an entry in the database.

    So, I searched around and found this same type of error back when Beta 1 was released. This post showed how to edit the cache_rebuild.js file and change the timeout value.

    In the Beta 1 release it was 30000 which people added an additional 0 to to make it 300000 as a timeout.

    In the Beta 2 release it is 60000, so I added an additional 0 making it 600000 as a timeout and it process through the entire installation.

    Since this was an issue in the first Beta and it's still an issue, even though it's gone from 30000 to 60000 maybe they need to increase this a little more? Dunno.. I have it working and can play again! Yah!

    Thanks for your help!

    Jamie
     
    Blandt likes this.
  13. Blandt

    Blandt Well-Known Member

    Alright :)
     

Share This Page