1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed Could not determine temp directory

Discussion in 'Resolved Bug Reports' started by z3r010, Oct 5, 2010.

  1. z3r010

    z3r010 Member

    I'm getting the following error on install

     
  2. Deceptor

    Deceptor Active Member

    Getting the same error, local IIS 7.5
     
  3. MentaL

    MentaL Active Member

  4. Deceptor

    Deceptor Active Member

    Thanks, manually assigned it to C:\php532\cache and installation went smoothly :)
     
  5. entertain

    entertain New Member

    Thanks! A manual path fixed this issue.
     
  6. z3r010

    z3r010 Member

    I cant get this working, can you give me the line of code you changed.
     
  7. Deceptor

    Deceptor Active Member

    File: library\Zend\Cache\Backend\File.php
    Line:
    Code:
            'cache_dir' => null,
    To:
    Code:
            'cache_dir' => 'C:\php532\cache',
    Change the path to w/e you like :)
     
  8. z3r010

    z3r010 Member

    Got it I'd put write permissions on the wrong dir :oops:
     
  9. Mike

    Mike XenForo Developer Staff Member

    You really should do that with php.ini. Try doing an upload - does it work? If not, you really need the upload_tmp_dir.
     
  10. twollert

    twollert Active Member

    Same problem here:

    during installation (step 2b)

    Any suggestions?
     
  11. ENF

    ENF Well-Known Member

    Couple of notes after Mike's comment:

    PHP 5.3.3 / IIS 6 / FastCGI

    Fresh configuration on a new server, resulted in the error noted in this thread.

    I had to configure the PHP.INI correctly with the upload_tmp_dir variable and assure that the rights were set correctly.

    After doing this, the install continued successfully. (Without editing XenForo files)
     
  12. Two Worlds

    Two Worlds Member

    I created a tmp/ folder an set permittions to 777.

    I solved this by adding this line to my php.ini:

    Now everything works fine !
     
  13. Mike

    Mike XenForo Developer Staff Member

    Have a fix for this now, though the upload_tmp_dir change is probably preferable. (As if you get this error, without it, I suspect uploads will fail.)
     
  14. mikoo

    mikoo Active Member

    ... still getting the mistake. Did you fix the problem by now?
     
  15. Luciano

    Luciano Member

    I get this errorduring install on a shared server where I have no access to the php.ini..
    Any suggestions?
    Luc
     
  16. Mike

    Mike XenForo Developer Staff Member

    There are changes for beta 2 for this, but they are significant.
     
  17. mikoo

    mikoo Active Member

    ... is there a chance beta 2 will be released soon? Fiddling around with the code is not really one of my favourite games :rolleyes:.

    Many thanks in advance...
     
  18. mikoo

    mikoo Active Member

    ... I finally fixed the problem for me. In case anyone might have the same problem, this could possibly help you, too:

    Open this file:

    lib/zend/cache/backend/file.php

    Alter this file as follows:

    old:

    protected $_options = array(
    'cache_dir' => 'null',

    new:

    protected $_options = array(
    'cache_dir' => '/tmp',
     
  19. Boofhead

    Boofhead Member

    Thanks! Worked for me too.:D
     
  20. erich37

    erich37 Well-Known Member

    I am also getting this issue with "php.ini" and "upload_tmp_dir" an XF-installations.

    So I have to contact the hosting-company each time to set this configuration for the php.ini for me, as I can not access the php.ini myself.

    For Beta2 this is being fixed ?
     

Share This Page