Convert YouTube videos straight to BB code when imported via RSS feed.

sbj

Well-known member
I am a newbiew to xenforo. i tried to google how to do this but no luck. how do i enable that setting: enable embedded videos?
It's very easy. You should have searched in the ACP :).

202731

Or in other words:

ACP->Setup->Options->Media Embedding

202732

where you will find this:

202733
 

srimal

Member
It's very easy
Did not realize you could search like that. Will do that moving forward. Thanks.


In my setting it is already enabled.
202746

My RSS import settings looks like this:

202747

When I do Import and go see the forum, it is blank. Am I missing something?
 

sbj

Well-known member
When I do Import and go see the forum, it is blank. Am I missing something?
First, check if your url is a valid rss url. It looks like to me though, but just to be sure.

Second. You selected "every 60 minutes". So you have to wait for the cron to be run.

To see your crons, go to ACP->Tools->Cron entries

202752

Not sure if it is the "RSS feed" cron or the "Feeder" cron which is the correct one for it. I think it is the feeder one.
You see below the crons when the next time is that they will run. Of course only, if someone is on the website active to trigger the cron (you need a visitor for crons to run, at least one). If no visitors are on the site, no crons run. They run when a visitor is online.

Anyway, see that they are activated like above (the blue circle on the right side must be on the right side). And if you don't want to wait for the crons to run, just click on the "circle shaped arrows" on the right side. It then runs the cron immediately after you press that button. And then you should see the threads in your destination forum.
 

srimal

Member
First, check if your url is a valid rss url. It looks like to me though, but just to be sure.

Second. You selected "every 60 minutes". So you have to wait for the cron to be run.

To see your crons, go to ACP->Tools->Cron entries

View attachment 202752

Not sure if it is the "RSS feed" cron or the "Feeder" cron which is the correct one for it. I think it is the feeder one.
You see below the crons when the next time is that they will run. Of course only, if someone is on the website active to trigger the cron (you need a visitor for crons to run, at least one). If no visitors are on the site, no crons run. They run when a visitor is online.

Anyway, see that they are activated like above (the blue circle on the right side must be on the right side). And if you don't want to wait for the crons to run, just click on the "circle shaped arrows" on the right side. It then runs the cron immediately after you press that button. And then you should see the threads in your destination forum.

Thanks for your help. I was trying to manual import to test, anyways nothing worked so i went ahead and deleted and recreated the importer, all started to work finally. not sure what was wrong..
 
  • Like
Reactions: sbj

BirdOPrey5

Well-known member
If it's of any help, this is what I use for YouTube RSS Feeds... Works well.

Code:
A video by: {author}

[url]{link}[/url]

[url="{link}"]Direct YouTube Link - {title}[/url]
 

srimal

Member
If it's of any help, this is what I use for YouTube RSS Feeds... Works well.

Code:
A video by: {author}

[url]{link}[/url]

[url="{link}"]Direct YouTube Link - {title}[/url]
If you do that, the video wont be embedded and the users will have to click the link which opens the link in youtube. but if you put just {link} in the template it willembed the youtube video right in your post so that the users can play the video without leaving the forum.
 
  • Like
Reactions: sbj

BirdOPrey5

Well-known member
If you do that, the video wont be embedded and the users will have to click the link which opens the link in youtube. but if you put just {link} in the template it willembed the youtube video right in your post so that the users can play the video without leaving the forum.
It's always embedded fine for me. :confused:
 
Top