Convert Image All

Convert Image All 6.8

No permission to download

CJP

Member
What's a safe Limit to set for number of images to grab at a time. I'm worried if my members have linked to images at the same site over the years that my IP will get banned for scraping... What max are people setting?
 

misteraven

Member
Hey I am getting the 500 Internal server error while using the convert image all addon.

Please help me to solve this issue.converimageadmin.png converimagepublic.png
 

Robert9

Active member
I have the problem with around 3000 dead pictures from extern sources (from the last 13 years).
While the script cant delete them i cant go on with existing pictures, right?
Is there a solution to delete this pictures, please?

Ok, i can solve it with start from or with changing asc to desc in the select from ...

In my test-borad (at a second server) i cant use the script at all. Is there any logging to see what´s going on? I always get "Sucessful ..." and i have no entry in the log-file. May the log-file should be checked from the script to help fining erros, and may the script should check if the pictures are really converted before showing "Successful ..." message.
 
Last edited:

Robert9

Active member
I have a test-server where i cant use the both addons. Today i found the error, i am not allowed to set a dir to 777. Now the addon convertimage is running (ImageMagick PECL is set in options > attachments), bit the convertimageall still dont work. How this is possible? Is there any difference between the scripts that can make the problem, please?
 

Breixo

Well-known member
Hi @AndyB
I used to convert images with the addon MetaMirror. It turned hotlinked images into images at own server.
Resulting this code:
Code:
[IMG]https://xxx.com/data/MetaMirrorCache/img854.imageshack.us_img854_9841_shot000001mm.png[/IMG]
I tried to convert them into attachments but it doesn't work.
Do you know why? I can only think of two reasons:
a) not working at same domain
b) too long image

Thanks in advance!

PD: probably second reason:
"Please ensure that the name of your file is less than 100 characters long."
2017-03-27_2004.png
I'd like to test it with a higher value but have no clue of where to change it. Just google it and still without ideas :(
 
Last edited:

dethfire

Well-known member
So you run this first once for all current posts and then install Convert Image which converts on new posts?
 

CTXMedia

Formerly CyclingTribe
thanks, that is confusing, why aren't they together?
I assume the Convert Image add-on came first, allowing attachments to be converted as they are uploaded to posts - and then afterwards either Andy (or someone else) thought it would be great if you could go back through all your prior attachments and run the same process on them ... hence this extra batch "All" add-on. (y)
 

CTXMedia

Formerly CyclingTribe
TBF it does say you should install the Convert Image add-on here:

upload_2017-3-28_14-37-16.png

... but it doesn't specify that it is essential/required, and so I ignored it on the basis I would look at this "other" add-on after I had completed the batch conversion.

Perhaps it should be more explicit and say it is REQUIRED to make this batch add-on work? @AndyB
 

CTXMedia

Formerly CyclingTribe
No, this add-on needs Convert Image to be installed too (I figured this out when trying to use this add-on solo when I migrated to https). (y)
CORRECTION: Actually, I'm wrong. This add-on works independently of the other - my mistake. I remembered having issues when I first installed it, but @AndyB kindly reminded me that it was an issue on my server, not a problem with the add-on (I'd installed the "common" Imagik package, but not the core files). :oops:
 
Last edited:

Breixo

Well-known member
Hi @AndyB
I used to convert images with the addon MetaMirror. It turned hotlinked images into images at own server.
Resulting this code:
Code:
[IMG]https://xxx.com/data/MetaMirrorCache/img854.imageshack.us_img854_9841_shot000001mm.png[/IMG]
I tried to convert them into attachments but it doesn't work.
Do you know why? I can only think of two reasons:
a) not working at same domain
b) too long image

Thanks in advance!

PD: probably second reason:
"Please ensure that the name of your file is less than 100 characters long."
View attachment 150316
I'd like to test it with a higher value but have no clue of where to change it. Just google it and still without ideas :(
Solved after enabling "Follow redirects" :)
Thanks @AndyB for your help!
 

dethfire

Well-known member
Running this now with 6m posts. It's extremely slow. Does it perform a table scan every reload to get more posts?
 

teletubbi

Well-known member
You should not delete the folder. Only empty it.
It is just used temporarily to change the external pictures into attachments.

The attachments are stored afterwards in another folder and don't get lost after empty the tmp folder.
 
Top