1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed "Contact Us" functionality not as expected

Discussion in 'Resolved Bug Reports' started by Rob, Sep 11, 2014.

  1. Rob

    Rob Well-Known Member

    Emails sent using the contact us feature are received fine, and appear to have come from the user, however, hitting reply does not reply to the user, it replies to the board url.

    I'm using the default transport method with the -f parameter.
  2. Mike

    Mike XenForo Developer Staff Member

    They were changed in 1.4 to use a Reply-To header, due mostly to a lot of locked down SMTP servers and some bad anti-spam implementations.

    What are you using to reply to the mail? If you look at the headers, do you see a Reply-To line?

    We did have one report of this during the beta but I could never reproduce it.
  3. Rob

    Rob Well-Known Member

    I'm using gmail.... which is quite popular. I'll check the headers, one sec
  4. Rob

    Rob Well-Known Member

    Hmmm... there is a reply-to header.... and it appears to be set correctly. Is this a google bug? I find it hard to believe the most popular email service would not respect standards. I'm sure other google users are not facing this so not sure whats wrong here.

    This is happening when the person is NOT a member - I will check how emails from members function now
  5. Mike

    Mike XenForo Developer Staff Member

    Are you pulling another external account into Gmail? (Particularly, is that the account where this mail went to?)
  6. Rob

    Rob Well-Known Member

  7. liv4spd

    liv4spd Member

    I am having the same problem as Rob. It is king of annoying.
  8. Rob

    Rob Well-Known Member

    Ok, it appears the exact thing happens regardless of whether the user is logged in or not.
    The board url is actually an alias of my real account, since I want to receive replies to them.

    The email appears in all my gmail clients (web and mobile) as though it came from me personally. If I reply from my mobile client, the reply is routed correctly. It only appears to affect the web based version of gmail. @liv4spd can you confirm the same?
  9. Mike

    Mike XenForo Developer Staff Member

  10. Mike

    Mike XenForo Developer Staff Member

    It does appear that this is the case. If your contact email is the same as your default email and you use Gmail, it just ignores the Reply-To header.
  11. Rob

    Rob Well-Known Member

    Ok, if you have your board email address set to use exactly your regular email address, then this happens. I'd imagine this is quite a common set up.
    I'll work around it but google sucks.
    BassMan and SneakyDave like this.
  12. Rob

    Rob Well-Known Member

    This can be worked around by setting your board email address to be an alias of your gmail account.
  13. cdub

    cdub Well-Known Member

    I'm still getting the same problem - even after changing the board e-mail address. strange
  14. The Dark Wizard

    The Dark Wizard Well-Known Member

    I'm also having the same problem, changing the email does not help with the issue in the slightest.
  15. Rob

    Rob Well-Known Member


    I logged into my gmail, went to "manage the domain", found my user account... added an alias for it.
    I then put my alias in as a the board email and this problem is no more.

    I should point out im using google apps on my domain, not sure if that matters.
  16. Mike

    Mike XenForo Developer Staff Member

    I've added an option for the next 1.4 release to return to the 1.3 setup with contact emails ("Sender info in From header on contact emails") which should allow this to be worked around if you're using Gmail and are affected.
    cdub and CyclingTribe like this.
  17. Rob

    Rob Well-Known Member

    I like the thinking here! Thanks!
  18. Bram

    Bram Well-Known Member

    Upgraded to 1.4.2 and I am still having this issue that I am replying to myself.
  19. Mike

    Mike XenForo Developer Staff Member

    You need to enable the option mentioned above and in the release announcement (in email options).
    Rob and Bram like this.

Share This Page