1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

As Designed Contact Details - can't save changes

Discussion in 'Resolved Bug Reports' started by Steve F, Mar 18, 2015.

  1. Steve F

    Steve F Well-Known Member

    On my iPad and iPhone I am unable to save changes on the Contact Details page. Trying to disable "Receive email when a new conversation message is received". Not at my desktop so I can't verify if the result is the same, password is only required for an email change correct?

    When the page loads the email and password fields are auto filled, I clear those fields untick the the receive email option then hit save and get this error. If you can see both fields are blank..

  2. Steve F

    Steve F Well-Known Member

    I may have jumped the gun there, I think you have to have the email field filled in? Works that way with the password filled empty...sorry.
  3. Mike

    Mike XenForo Developer Staff Member

    Correct, the email field is normally filled in with your current email. You blanking the email out has the code detecting it as changed and thus requires your password.
  4. Steve F

    Steve F Well-Known Member

    The issue was on my phone, instead of it auto filling my email it was my username thus making it immediately confusing.

    Also I wasn't absolutely sure which email I had in use here as I thought I had changed it to a gmail address, which is what I use in the customer area. Didn't want to input the wrong one just to save the setting and the system changing my email.

    Would it be possible to make the current email hardcoded or hint saying what the current one is? Obviously auto fill was the confusing factor on my device.
  5. Mike

    Mike XenForo Developer Staff Member

    This really seems like an issue with the autofill as it could come up in many places. The autofill actively replacing the value that was provided for the page seems very broken to me.
  6. Steve F

    Steve F Well-Known Member

    Auto fill seems to be pretty aggressive with iOS 8, as I'm typing this message I have the option to use AutoFill Password. Which I hadn't really noticed until recently.

    Attached Files:

Share This Page