• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Constant avatar errors

viper357

Active member
#1
Hi

In my error log file in cpanel I have thousands of these errors every day, is there anything I can do to stop them? A lot of them seem to be repeated, all day long, thanks.

2016-10-14 13:37:29.814 [INFO] [169.0.52.34:56582] File not found [/home/marineaq/public_html/data/avatars/s/3/3717.jpg]
2016-10-14 13:36:48.791 [INFO] [105.228.189.35:60419] File not found [/home/marineaq/public_html/404.shtml]
2016-10-14 13:36:48.791 [INFO] [105.228.189.35:60419] File not found [/home/marineaq/public_html/data/avatars/s/10/10995.jpg]
2016-10-14 13:36:23.048 [INFO] [169.0.52.34:56533] File not found [/home/marineaq/public_html/404.shtml]
2016-10-14 13:36:23.048 [INFO] [169.0.52.34:56533] File not found [/home/marineaq/public_html/data/avatars/s/9/9734.jpg]
2016-10-14 13:36:23.028 [INFO] [169.0.52.34:56543] File not found [/home/marineaq/public_html/404.shtml]
2016-10-14 13:36:23.028 [INFO] [169.0.52.34:56543] File not found [/home/marineaq/public_html/data/avatars/s/3/3717.jpg]
2016-10-14 13:36:21.385 [INFO] [169.0.52.34:56538] File not found [/home/marineaq/public_html/404.shtml]
2016-10-14 13:36:21.385 [INFO] [169.0.52.34:56538] File not found [/home/marineaq/public_html/data/avatars/s/9/9734.jpg]
2016-10-14 13:36:21.005 [INFO] [169.0.52.34:56540] File not found [/home/marineaq/public_html/404.shtml]
2016-10-14 13:36:21.005 [INFO] [169.0.52.34:56540] File not found [/home/marineaq/public_html/data/avatars/s/3/3717.jpg]
 

viper357

Active member
#3
Not sure how they could have been deleted, maybe an error in the initial import from vb? If somebody changes their avatar does it get deleted from the server?
 

viper357

Active member
#6
So it seems like the default 48x48 avatar has been deleted from a lot of the members. Is there any kind of query I can run to re-create or re-build the default avatar for all members that don't have one?
 

Brogan

XenForo moderator
Staff member
#7
There is no default avatar.

If a member doesn't upload one, the default image is served instead but it is not associated with their account in any way.
 

Chris D

XenForo developer
Staff member
#8
Have the ones with missing avatars ever been banned in the past, and if so, do you use the Special Avatar for Banned Members add-on? There was a bug on that which may have incorrectly left the avatar_date field populated which would make XF think there should be a custom avatar when there is not. If you think it is related to that add-on, please post in the discussion thread for that resource.