• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Consistent Server Errors

#1
I'm not sure why these errors are coming up. Though these errors are not causing issues throughout the site, I would rather not login to my control panel and be greeted with 2-10 errors every week or so.

ErrorException: Undefined index: host - library/XenForo/SitemapHandler/Abstract.php:90
Generated By: Unknown Account, Today at 3:22 AM

#0 /var/www/play.mcworldmap.com/public_html/library/XenForo/SitemapHandler/Abstract.php(90): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/play.m...', 90, Array)
#1 /var/www/play.mcworldmap.com/public_html/library/XenForo/SitemapHandler/User.php(44): XenForo_SitemapHandler_Abstract->getCanonicalPaths()
#2 /var/www/play.mcworldmap.com/public_html/library/XenForo/Deferred/Sitemap.php(160): XenForo_SitemapHandler_User->getData(Array)
#3 /var/www/play.mcworldmap.com/public_html/library/XenForo/Deferred/Sitemap.php(90): XenForo_Deferred_Sitemap->_buildSitemap(Object(XenForo_SitemapHandler_User), 0, 7.9999988079071)
#4 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_Sitemap->execute(Array, Array, 7.9999988079071, '')
#5 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999988079071, '', false)
#6 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 /var/www/play.mcworldmap.com/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}

ErrorException: Undefined index: scheme - library/XenForo/SitemapHandler/Abstract.php:91
Generated By: Unknown Account, Today at 3:22 AM

#0 /var/www/play.mcworldmap.com/public_html/library/XenForo/SitemapHandler/Abstract.php(91): XenForo_Application::handlePhpError(8, 'Undefined index...', '/var/www/play.m...', 91, Array)
#1 /var/www/play.mcworldmap.com/public_html/library/XenForo/SitemapHandler/User.php(44): XenForo_SitemapHandler_Abstract->getCanonicalPaths()
#2 /var/www/play.mcworldmap.com/public_html/library/XenForo/Deferred/Sitemap.php(160): XenForo_SitemapHandler_User->getData(Array)
#3 /var/www/play.mcworldmap.com/public_html/library/XenForo/Deferred/Sitemap.php(90): XenForo_Deferred_Sitemap->_buildSitemap(Object(XenForo_SitemapHandler_User), 0, 7.9999988079071)
#4 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(294): XenForo_Deferred_Sitemap->execute(Array, Array, 7.9999988079071, '')
#5 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(428): XenForo_Model_Deferred->runDeferred(Array, 7.9999988079071, '', false)
#6 /var/www/play.mcworldmap.com/public_html/library/XenForo/Model/Deferred.php(373): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#7 /var/www/play.mcworldmap.com/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#8 {main}
 

Chris D

XenForo developer
Staff member
#2
This would usually happen if your Board URL option has a weird value (or it's missing).

Check Admin CP > Options > Basic Board Information.