Fixed Confusing compatibility requirements 2.2.14 patch 1

Okay so I understand the confusion but this is pretty much correct.

Your version of PHP is outdated. PHP 7.4 is old, and you should ideally be using a newer version.

In the future (XF 2.3), we will require a higher minimum version (7.2.5). You exceed this requirement, but that does not change the fact that your version of PHP is outdated.

We do recommend PHP 8.1 (or 8.2 more accurately now).

So all of these things are true and correct but they're just presented a little confusingly.
The logic and wording may change slightly. It may be < 8.0.0 in the future, rather than < 8.1.0. I haven't fully decided yet.

On the one hand, I think it's reasonable for people to have older versions brought to their attention, and PHP 8.0 is 4 years old this year. On the other hand, thinking about where we might want to be in the future, if we made PHP 8.0 the minimum requirement in, say, XF 3.0 or XF 3.1 then it's probably reasonable to call out people running below 8.0 rather than below 8.1.

Either way, I think now XF 2.2.14-15 has much better PHP 8.2 compatibility, the underlying message still stands: we recommend upgrading.
Maybe so?
Your used version of PHP (7.4) is outdated, you should update from security reasons. Future versions ...

I think that can be the best wording for best understanding.
IMHO the message should be shown whenver the detected PHP version is less than the maximum PHP version supported by XenForo and the recommended version should be the maximum supported version as well.

This should make admins more aware of this so they hopefully will upgrade faster allowing XenForo to move on to newer PHP versions faster as well.
Last edited:
After some thought, I think I agree with @Kirby. This does mean that users with PHP 8.1 will see a warning, but we have modified the text to be a little more succinct:


We're not going to complicate matters where it comes to maximum versions, however. While we do not currently recommend PHP 8.3, this will be marked as recommended:


This change will be reflected in today's XF 2.2.15 release.

We will aim to improve PHP 8.3 compatibility in a subsequent release, but I don't think the issues this brings are quite as extensive as previous PHP versions.
Thats better. Short but all needed informations. :-)

XF 2.2.15 today ??? 😳 Good that I havnt updated at 2.2.14 PL1 and PL 2 ;) :D
Top Bottom