1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Server Issue Configured xF as a subdomin, now logout gives an error

Discussion in 'Resolved Bug Reports' started by SneakyDave, Dec 17, 2010.

  1. SneakyDave

    SneakyDave Well-Known Member

    I had xF setup fine in my site's directory, but I decided to create a subdomain to that directory, so I setup the DNS, and changed the Board URL in the "Basic Board Information" admin settings.

    It doesn't look like there are any other settings to change, other than a few static links I had to node pages I created.

    But if I'm on the forum home of the sub domain, and click the "Log Out" button, I get a xF "The requested page could not be found" error, although the session is killed. The log out link looks like this:
    http://community.xxxxxx.yyy/logout/?_xfToken=1,1292597269,9ac74b4de4a6364ad19e6a2bae4864d11ce264ce

    The same problem occurs when I try to log in from the forum home page, but the authentication works ok.

    Logging in and logging out of the admin area appears to not be affected.

    I rebuilt all the cache in the forums just in case, and cleared my browser cache, but is there something else to look at? Maybe a redirect problem after authentication or the session is killed? Everything else appears to work ok with xF on a subdomain.

    CORRECTION: the problem only seems to happen on logging out of the forum home, I think logging in from the forum home works ok now.
     
  2. SneakyDave

    SneakyDave Well-Known Member

    Another weird thing is that I can't reproduce the problem in Chrome or FF, it appears to only exist in IE. Maybe related, but I also tried to log in from the forum home in IE, with the drop down sign in, provided invalid creditials, tried to log in again on the "real" log in page, was successful, but gave me an error:
    "This action is available via POST only. Please press the back button and try again"

    And the URL is pointing to: http://community.xxxxxx.yyy/login/login
     
  3. Floren

    Floren Well-Known Member

    Are you using Nginx? That URL looks like a classic configuration loop.
     
  4. SneakyDave

    SneakyDave Well-Known Member

    Yes I am, I thought the same thing, but it only seems to be happening with IE, and all the other links work correctly, from what I can tell.

    I reverted back to a directory structure, but I'll play with it a bit more when I get some other things ironed out.
     
  5. Floren

    Floren Well-Known Member

    It is related how the redirect loop is handled in IE.
    Check your config, I saw this happening many times on other client sites. :)
     
  6. SneakyDave

    SneakyDave Well-Known Member

    I checked it, the subdomain server parameters for nginx are identical to the root/default server parameters, except for the "location" and "root" directives. But whatever, I'll tackle some time in the distant future. Thanks for the suggestion.
     
  7. SneakyDave

    SneakyDave Well-Known Member

    I can confirm that the problem was with my nginx configuration.
     

Share This Page