1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Code to call forum title description

Discussion in 'XenForo Questions and Support' started by TazDevilLooney, Dec 15, 2010.

  1. TazDevilLooney

    TazDevilLooney Active Member

    Hi people,

    Im trying to call the big bold black description at the top of the page. 'General Support and Questions'
    I wish to move this to a diffrent location. There is also a colour i cant figure out how to change. Any idears?

    [​IMG]

    I just require the raw code for the discription. The placement is already sorted.
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Do you want to change "Main Forum" to "General Support and Questions" ?
    You do that in the ACP -> Applications -> Display Node Tree.

    Click on the node named "Main Forum" and change the title.

    The "Selected Threads" link is this css:
    Code:
    a:link, a:visited {
    color: #176093;
    text-decoration: none;
    }
     
  3. TazDevilLooney

    TazDevilLooney Active Member

    Nope im after the code for the discription so i can set it in the black thread.
     
  4. Brogan

    Brogan XenForo Moderator Staff Member

    If you place the forum title there, where will your page nav links go?
     
  5. TazDevilLooney

    TazDevilLooney Active Member

    Arr i see what you mean about the nav bar, umm i'll have to have a re-think on that one. Thankyou for help
     
  6. TazDevilLooney

    TazDevilLooney Active Member

    It amazing what you can do when your really, really, really bored......... I'll have a go at the header tomz :)
    Still can't get the blue text though. :)

    [​IMG]
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    The code that Brogan posted is in this template:

    Admin CP -> Appearance -> Templates -> xenforo.css

    Code:
    a:link,
    a:visited
    {
    	color: @primaryMedium;
    	text-decoration: none;
    }
    
     
  8. TazDevilLooney

    TazDevilLooney Active Member

    Thanks for the reply bruce, however it changes all the link colors to white. I have a white background set it tends to hide the forum text.
     
  9. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    For some reason I am having trouble setting an exception for that link color in CSS. But here is a bad way to do it if you are interested:

    Admin CP -> Appearance -> Templates -> inline_mod_controls

    Replace this code:

    Code:
    <a class="SelectionCount">{$selectedItemsPhrase}: <em class="InlineModCheckedTotal">0</em></a>
    
    ...with this:

    Code:
    <a class="SelectionCount" style="color: #000000;">{$selectedItemsPhrase}: <em class="InlineModCheckedTotal">0</em></a>
    
    Use any color code you want.
     
  10. TazDevilLooney

    TazDevilLooney Active Member

    Spot on Jake, Thankyou very much. Just could not find that one. :)
     
  11. TazDevilLooney

    TazDevilLooney Active Member

    [​IMG]


    Hi again people, I really need some help with a couple of things. Any info would be greatfully recieved.

    I have 2 items in the picture.

    Item 1 : When mouse hovers over tabs i get a blue background and white text. Where could i change this so the background is transparent and the text is black.

    Item 2 : Is there any way of removing the last arrow from the end of the row.
    Forum
    Forum -> Main Category
    Forum -> Main Category -> Blar Blar

    Cheres people :)
     
  12. Brogan

    Brogan XenForo Moderator Staff Member

    Item 1: is .navTabs .navTab.PopupClosed .navLink:hover

    Item 2: Are those the breadcrumbs? It looks like you will need to edit the foreach loop from the breadcrumb template to remove the last arrow.
    Code:
                <xen:if is="{$navigation}">
                    <xen:foreach loop="$navigation" value="$breadcrumb" i="$i" count="$count">
                        <span class="crust"{xen:if $microdata, ' itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"'}>
                            <a href="{xen:raw $breadcrumb.href}" class="crumb" rel="up" itemprop="url"><span itemprop="title">{xen:raw $breadcrumb.value}</span></a>
                            <span class="arrow"><span>&gt;</span></span>
                        </span>
                    </xen:foreach>
                </xen:if>
     
  13. TazDevilLooney

    TazDevilLooney Active Member

    Sweet, I'll get right on it. Thankyou Brogan
     
  14. TazDevilLooney

    TazDevilLooney Active Member

    Worked like a charm, thanks again Brogan :)
     
  15. Brogan

    Brogan XenForo Moderator Staff Member

    How did you end up doing it in the end?
    Another nested foreach loop for the arrow?
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    Won't that remove all arrows after the Forums breadcrumb?

    Edit: Not fair, you deleted your post :D
     
  17. TazDevilLooney

    TazDevilLooney Active Member

    Yes correct however i see your point, i now have

    1. Forum ->
    2. Forum -> Main Category
    3. Forum -> Main Category ? Blar Blar

    I was only looking at no.2 untill i started to explore i see what happend.

    LOL any tips, hehe
     
  18. Brogan

    Brogan XenForo Moderator Staff Member

    I think you'll have to remove the arrow from the main foreach loop and do a nested loop for the arrow, minus 1 count.
     
  19. TazDevilLooney

    TazDevilLooney Active Member

    Oh, my php is prity basic. I am able to disable the arrows for each loop. but i dont know how to add code to count. :)
     
  20. TazDevilLooney

    TazDevilLooney Active Member

    I have disabled all arrows in the bread crum template
     

Share This Page