XF 1.5 Clone istallation for test upgrade XF 1.5 to XF 2.2

Check the notes like:
Edit the the src/config.php file (library/config.php file if using XF1)
Because XF 2 uses the src folder while XF 1 uses the library folder.

It's just this folder name to look out for and sub it with "library" for your XF 1 test install.
  • Like
Reactions: tsi

the clone of the productive site to a test system on the same server worked quite well with the instruction.
Unfortunately I can't use it for testing the upgrade to 2.2 because I only can switch PHP in general to 8.0, only including the Xenforo 1.5 productive forum.

So I tried to install a clone on my local "Linux Mint 20" laptop.
php --version is 7.3.30, mysql is 8.0.26, the import of the original DB in a new mysql DB worked fine.
I copied all files from my current live site directory to the local apache directory

I changed the .htacces file like described in the manual:

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} -f [OR]
RewriteCond %{REQUEST_FILENAME} -l [OR]
RewriteCond %{REQUEST_FILENAME} -d
RewriteRule ^.*$ - [NC,L]
RewriteRule ^(data|js|styles|install) - [NC,L]
RewriteRule ^.*$ index.php [NC,L]

... and I changed the DB credentials in libary/config.php matching my local DB and added the following code like described in the manual:

$config['enableMail'] = false;

$config['cookie'] = array(
'prefix' => 'test_',
'path' => '/',
'domain' => ''

Unfortunetely I do not see any content in my browser.

Any ideas what could be wrong, or how to start with error search?

A blank page could be a suppressed error.

Try adding this to the config.php file:
ini_set('display_errors', true);

Can you navigate directly to the ACP and log in?
  • Like
Reactions: tsi
I just packed a simple phpinfo.php in the document root, I can open this file in the browser with the url localhost/phpinfo.php.

The index.php in the same path results in a blank page, even no error messages with the added line in config.php.

If ACP is the admin.php: localhost/admin.php has a blank page too ...
Try checking the server error log - you may need to enable logging in whatever stack you are using locally.

Thanks for your help!

Thanks to apache error log I located permission problems in document root, this is solved - now the next issue:

I receive the error message "An unexpected database error occured. Please try again later".

The mysql error log has no entries. A normal mysql login with the credentials in library/config.php works.
This is a database error (one of Zend_Db_Exception types) which will have the error message in the page source.

Right click and select view page source.


I suspect the DB credentials may be incorrect.
  • Like
Reactions: tsi
Thanks for your help!

... page source told me:
"<!-- The Mysqli extension is required for this adapter but the extension is not loaded -->"

... now I installed php7-mysql and activated it:

vi /etc/php/7.3/apache2/php.ini

service apache2 restart

root@thinkpad:/var/www/html# php -v
PHP 7.3.30-1+ubuntu20.04.1+deb.sury.org+1 (cli) (built: Aug 26 2021 15:56:09) ( NTS )

root@thinkpad:/var/www/html# php -m | grep mysqli

... "php -m" shows that "mysqli" ist loaded. This problem seems to be solved :)

... but next error:

"An unexpected database error occurred. Please try again later.
<!-- The server requested authentication method unknown to the client -->"

... any hint to step on?

For XF 1.5.24 the requirements are PHP 5.6 to 7.3 and MySQL 5.5 to 5.7.

I never tested 1.5 with MySQL 8 so can't confirm if it works or not.
  • Like
Reactions: tsi
Live could be easy ;-)

Starting from scratch with a 'new' mysql 5.7.35 installation, reimport dump from the live system ...
... and now it works :)

The start page shows up, I can reach admin.php ... and i can login :-)

Thanks a a lot!

Still hopefully a small problem:

I cant't reach Links of the startpage, like localhost/posts/34552/ ...

I receive a
"Not found
The requested URL was not found on this server"

admin.php works fine.

Just found another issue with my clone instance, hope this will not be a problem in my production system:

The threads where user uploaded pictures do not show longer the pictures but only the placeholder, like:



In this case I can see that the pictures are appended, but they are not longer embedded in the text ...

How can I solve this?
Last edited:
Top Bottom