1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Clicking pages, often it wants to download index.php

Discussion in 'XenForo Questions and Support' started by Matt51723, Feb 11, 2011.

  1. Matt51723

    Matt51723 New Member

    Ok so this is getting really reallllyyyy annoying. I'll often click a page and a download will start usually being "index.php" or "download.gz".

    Not sure why this is occurring, but I am using chrome if that helps.
     
  2. Mikey

    Mikey Well-Known Member

    This would be a problem with your server, it could be that you're gzipping pages twice, ask your host about it..
     
  3. Matt51723

    Matt51723 New Member

    Could this also be a XenForo related issue? This never happened on vBulletin.
     
  4. FredC

    FredC Well-Known Member

    I have this happen often using FF, it could be a browser configuration, but it used to happen alot to me on vB.com haha and of course one of my own sites but it never happened on one of my other sites hosted on the same server.
     
  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Try disabling gzip by adding this line to your library/config.php file:

    Code:
    $config['enableGzip'] = false;
    
    Does that fix the problem?
     
  6. Matt51723

    Matt51723 New Member

    It seems that it did. If this occurs again I'll come back. Thank you!

    Edit: Unfortunately it's occurred again, this time downloading admin.php. Forgot to mention it does that also.
     
  7. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Are any errors recorded?

    Admin CP -> Tools -> Server Error Log

    Also, try actually downloading the file when prompted. Sometimes the downloaded file will contain an error message.
     

Share This Page