1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Cleaning up SQL error after yanking Showcase

Discussion in 'General PHP and MySQL Discussions' started by KC Riley, Feb 22, 2016.

  1. KC Riley

    KC Riley Active Member

    Hey Guys,

    I just pulled the showcase add-on to improve my site's Page load speeds. I'm getting these database errors after deleting the Showcase add-on.

    What will I need to do to fix the following table errors?


    Admin Control Panel
    Server Error
    Mysqli prepare error: Table 'darkchil_canada.xf_nflj_showcase_item' doesn't exist

    1. Zend_Db_Statement_Mysqli->_prepare() in Zend/Db/Statement.php at line 115
    2. Zend_Db_Statement->__construct() in Zend/Db/Adapter/Mysqli.php at line 381
    3. Zend_Db_Adapter_Mysqli->prepare() in Zend/Db/Adapter/Abstract.php at line 478
    4. Zend_Db_Adapter_Abstract->query() in Zend/Db/Adapter/Abstract.php at line 825
    5. Zend_Db_Adapter_Abstract->fetchOne() in DailyStats/Model/DailyStats.php at line 179
    6. DailyStats_Model_DailyStats->getTotalShowcase() in DailyStats/Model/Counters.php at line50
    7. DailyStats_Model_Counters->getBoardTotalsCounter() in XenForo/Model/Counters.php at line 37
    8. XenForo_Model_Counters->rebuildBoardTotalsCounter() in DailyStats/Model/Counters.phpat line 76
    9. DailyStats_Model_Counters->rebuildBoardTotalsCounter() inDailyStats/ControllerAdmin/Home.php at line 7
    10. DailyStats_ControllerAdmin_Home->actionIndex() in XenForo/FrontController.php at line351
    11. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 134
    12. XenForo_FrontController->run() in /home/darkchild/public_html/uk/admin.php at line 13
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It appears to be related to an add-on for daily stats.

    You would be better off posting in that resource thread, or the showcase add-on thread.
     
    KC Riley likes this.
  3. markku

    markku Well-Known Member

    Disable ACP and Forum Display ShowCase options here:
    /admin.php?options/list/MWSDailyStats
     
  4. KC Riley

    KC Riley Active Member

    Thanks, this fixed it. Phew! I'm still learning some SQL commands. I was worried that was going to be harder.

    Thanks Markku.
     
    markku likes this.
  5. popr

    popr Active Member

    @KC Riley What kind of problems did you have with showcase? I have a big board and am considering installing it -- page speed is important for our site, though we do have a very powerful server.
     
  6. KC Riley

    KC Riley Active Member

    There's nothing wrong with Showcase. I have lots of add-on's running. I had to make some tough choices for pagelaod speed.

    Including custom add-on's I'll be at 38 add-on's. I may be getting rid of the troublesome XFA Extended cover add-on.

    Showcase will be reviewed at a later date. I'm running a Quadcore Xeon Dedicated server with 16 GB of ram.

    I'm also using Litespeed with HTTP2.

    A lot of the issues with page load speeds have nothing to do with your server. Most of the time it's the result of having too many HTTP requests.

    Most smartphones can easily handle 28 - 32 HTTP requests and 756 KB page size while loading a page in under 2.5 seconds.

    Once you get past 958 Kb page size and 40+ HTTP requests, you're site will start to run like snail .

    I haven't set-up a CDN yet. I'll have to see what impact it will have.
     

Share This Page