XF 1.2 Chrome Login Dropdown Not Working

beanfan78

Active member
For some reason only in Chrome the Login/Register box does not drop down. Had a few people contact me about it and I duplicated it. I thought it was cloudflare and minifying js scripts but I disabled that. Has anyone else had issues with this? I want to make sure it's not the way I set something up. It is on 1.2RC1 and the site is www.milpages.com/forum. TIA!
 

beanfan78

Active member
Sorry I didn't add that this is the stock style, only the sitemap for xenforo plugin and xen media gallery are installed. Otherwise it's stock. I tried with them disable as well. Works in FF and IE without issues.
 

beanfan78

Active member
Thanks Matt, I didn't try on the mobile. I was on the desktop. Will take a look now though on iPad, and Android.
 

Jeremy

Well-known member
The CSS definition for #loginBar .textCtrl has an unsupported pseudo prefix: -webkit-autofill. This is causing Chrome to error out from that. If you remove it, it should work.
 

Mike

XenForo developer
Staff member
It's part of the JS. The fact that it's not triggering here means that something must be different.

I do note that your HTML source is still different from the stock output. Tabs are removed and there are references to "rocketscript" which is part of CloudFlare, so I suspect that's the cause.
 

beanfan78

Active member
Cloudflare is disabled and it works now. That was the issue so I guess I will be saying goodbye to cloudflare for now. Thank you everyone for lending a hand.
 

Tracy Perry

Well-known member
Cloudflare is disabled and it works now. That was the issue so I guess I will be saying goodbye to cloudflare for now. Thank you everyone for lending a hand.
Try disabling the RocketLoader in your cloudflare performance settings if it's enabled. That's been known to cause problems and why it's shown as BETA.
 
Reactions: rdn

yavuz

Well-known member
Yes, I'm using it. Is there a workaround we can use cloudflare with the rocketloader enabled?
 
Top